How do I change grid height

0 favourites
  • 8 posts
From the Asset Store
Snap to visible grid - perfect solution for any game genre
  • I'm following along with this tutorial:

    When it gets to the part about making it Snap to Grid it also says to make the grid 16x16, but I'm only able to make the width 16, while the height refuses to change from 32 to 16, so I'm left with 16x32. Am I doing something wrong, or is this a bug? Or maybe my C2 download messed up?

    Also, I should mention that after I've changed the width to 16, it won't allow me to change it to 32. Not that I want to, but I just tried it to see what would happen. Nothing happens. View closes and the grid is still 16x32. Any help would be much appreciated. Thank you.

    Edit: I don't have enough rep to post links. The tutorial I was referring to is titled "Learn how to use tilemap by making a platform game with it!"

  • I closed out that project and started a new one. In this project, the first thing I did was go to View, checked the Snap to Grid box, and changed the height first and the width second. This time the height changed to 16 and the width stays at 32 and it won't let me change it. This seems like a pretty odd problem.

  • You have to click in the layout window, then you'll see the change.

  • Thanks for the reply blackhornet.

    Unfortunately, that's not the problem. When I go to View I check the Snap to Grid box and then View automatically closes. I open View back up and change the width and height and click the layout window and only the first thing I choose to change changes. The second one stays the same. Also, if I try to change either one again, they will both stay the same, so I can only change one of them and after that neither one will change for me. I'm beginning to think my Construct 2 is messed up somehow.

  • If you change the value and then click on the layout it won't save the change. If you click somewhere on the toolbar or press enter it will.

  • Yeah, I can see how that would make sense. But that's not working. I'm only able to change one of the values once, then both of the values are locked in and I can't change them. Is it possible that something in my version of C2 is corrupt?

  • I finally figured out a solution. Not that this seems like a common problem among the community, but just in case here's what I had to do. Right click in the top ribbon to open the ribbon options and uncheck the Minimize Ribbon box. The ribbon will now no longer go away and you are able to adjust the grid size. I don't know why this changed anything but it worked.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • So weird, i have the same problem. But the pin toolbar fix works great!

    Thanks, this was driving me crazy!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)