0 Favourites

WebGL Effect to Object

  • Hello Guys!

    I have this "orb1" and "orb2" sprites. They are the same sprite, but I need one to be green and the other to be red. I think that I can use WebGL to change their color.

    But... I just can't seem to find a way to apply this effect. Yeah, that's it, I don't know how to apply a WebGL effect to an Object. I've looked everywhere, and didn't find an answer.

    Please help :(

  • It just so happens I'm making a game with some sprites called 'orb1' and 'orb2' right now. I'm also using a lot of WebGL including colour changes.

    You could try applying the WebGL effect called "AdjustHSL" and have the hue altered depending on whatever it is in your game that determines the 'orb' colour. The other way would be to avoid WebGL and simply have a set of animations for the sprite that you can switch for each instance, depending on your parameters.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • It just so happens I'm making a game with some sprites called 'orb1' and 'orb2' right now. I'm also using a lot of WebGL including colour changes.

    You could try applying the WebGL effect called "AdjustHSL" and have the hue altered depending on whatever it is in your game that determines the 'orb' colour. The other way would be to avoid WebGL and simply have a set of animations for the sprite that you can switch for each instance, depending on your parameters.

    Haha, that's a nice coincidence!

    But, problem is: I don't know how to apply these effects! I've looked everywhere (not everywhere, because I didn't find anything).

  • Select the sprite within Layout view and look to the right of your interface. Where it says "Effects - Add/Edit" left-click on "Effects". Within the Effects Interface select the plus ("+") icon and scroll all the way to the bottom for WebGL effects.

  • I don't know what's going on. There's no add/edit effect for objects. Only for layers...

    Maybe it's a bug?

  • You must have your 'Properties Bar' hidden or lost somewhere then. I think the default position for it is actually on the LEFT of your screen.. but if you do have the properties bar up then effects are like right there in the middle of it!

  • Hope this image helps show what should be ticked and where the bar should be located by default

    dl.dropbox.com/u/74175978/Image_Help.png

    Edit*

    Sorry for the bad paint writing, it was the fastest thing I could edit in

  • Richard, thanks a lot for your help. Now, I can see what's wrong...

    I don't have this option enabled, worse: my construct is kinda different from yours (mine is 117)

    Here is a screenshot:

    dropbox.com/s/1gp4mu7mdg4z9ya/What.png

    What should I do?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)
Similar Topics Posts Views Last Post
Unread sticky
276 261,907
gamecorpstudio's avatar
gamecorpstudio
Unread hot topic
164 38,105
totoe's avatar
totoe
Unread hot topic
125 11,831
DatapawWolf's avatar
DatapawWolf