0 Favourites

Blurry Pixelart?

  • So, I quite recently bought this great tool for simple game developing and I love it, I just encountered a problem with pixelart where as when I try to run the game it seems to blur them up in an attempt of smoothing the pixels out, which I don't want to happen to my pixel-art-sprites, in other words, I'd like to have them crisp and pixely, I googled around for a little and couldn't find any solution to the problem, I even went as far as taking a fast glance at the manual, yet I was left clueless to how to solve my problem...

    Here's a CAPX of a VERY simply test containing a VERY simple pixel-sprite which is for some reason smoothed out when it's played: Click me

    All help is appreciated and I thank you all in advance for the time I took from your day haha :)

  • I also have been having this problem. I have been resizing my pixel art with photoshop then placing them into my game, and that seems to fix them but if you re-size them in C2 they end up all blurred. Maybe this is some kind of bug.

  • oh haha thanks for the tip :) The pixel-resizing seems to have been a 'problem' since the first version of the... first version lol :)

  • I'd imagine most modern software assumes you want filtering when you rescale something...It doesn't sound like a bug, it just sounds like its doing something other than what you want...

    I'm new to C2 myself, so maybe someone else can be more help, but I think you want to make your game based on a low res window size like 320x240 and then have the game enlarge at run time WITHOUT filtered scaling... I'll report back if I get the time to figure out how to do this.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • If you are using webgl enabled, the filtering is automatic.

    Check in layout preferences, and you'll see options to turn webgl off, and set filtering to point, if you want to keep it.

  • If you are using webgl enabled, the filtering is automatic.

    Check in layout preferences, and you'll see options to turn webgl off, and set filtering to point, if you want to keep it.

    I think this broke in one of the latest builds. I used to keep WebGL off & pixel rounding on and the graphics would be perfectly fine, even when zooming in Chrome. Now they're blurry regardless of what settings I use.

  • IT WORKS! Oh thank you so much! awesome :) (to newt)

  • What version of C2 are you using helehole? Because I just tried what newt said with your .capx and it's still all blurred.

  • Release 79.4 (32 bit) Running on a Windows 7 Home Premium machine ;)

  • Hmm, I just cant get it to work with turning webgl off, and setting filtering to point. Maybe I just have a crappy pc. <img src="smileys/smiley6.gif" border="0" align="middle" />

  • all I did was actually just setting the filtering to point and poof! it was fixed ;)

  • Hmm, never mind, I tried exporting it and running it and it seems to still be blurry, but it works when previewing it though, weird :3

  • No, it's just not working for me I even cleared my browsers cache.

  • it works really great when I launch it through construct as a preview, but when I export it and launches it with Safari (the web browser) it seems to be all blurry and laggy :3

  • Wellwell, I'll go with the resizing it all in a photo-editor (paint.net for my part lol)

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)