Blurry Pixelart?

  • I'm aware the blurry graphics is annoying but the situation is tricky!

    You can force blocky (point sampling) resizing instead of blurry (linear sampling) resizing, by setting 'Sampling' to 'Point' in project properties, as you've found. However, it only has an effect in WebGL mode. Internet Explorer doesn't support WebGL, and Safari supports it but has it disabled by default AFAIK. Also, even in Chrome and Firefox, sometimes the user's computer does not support WebGL. For these browsers and users it falls back to the ordinary Canvas 2D renderer.

    The problem with the Canvas 2D renderer is there's no option to set the sampling mode. Browsers choose whichever they feel like! In Canvas 2D, sometimes it will use linear, and other times point. I've contacted browser makers to see if there's any way to force it, but the impression I got was it'd be fixed in a future version of CSS, which is probably a year away or more!

    So not much can be done I'm afraid. The only perfectly reliable way to do it is resize your sprites beforehand.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Oh haha I see the problem here haha, I'll go for resizing the image beforehand ;) Thanks for the help :)

  • Open Chrome

    Enter Chrome://Flags in the URL bar and press enter

    Enable "GPU Accelerated Canvas 2D"

    Play your game through Chrome

    Open tools and zoom in (or use Ctrl+mousewheel)

    Voila - Any zoom level with no blurry pixels! Press F11 for added effect.

    Good luck getting your players to get Chrome, though. People are afraid a S.W.A.T. team will bust down their doors 'bout 10 minutes after using it.

  • Whoop thanks for the tip :) The problem is that I can't seem to play the game locally on Chrome though, and it's for some reason really laggy on Safari lol

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)