0 Favourites

Loader layout and destroy object [BUG]

  • Hello, I'm using a loader layout, when loading is complete (loadingprogress = 1) I destroy an object but it seems to have no effect.

    I mean, can not you destroy objects in a loader layout?

    There is no information here https://www.scirra.com/tutorials/318/how-to-use-loader-layouts-to-make-custom-loading-screens

  • Do you have any other actions running on the loading is complete event, e.g. go to layout? If so test by commenting those additional actions out and just run the "loading is complete" event and "destroy object" action to check that those actions aren't preventing the object being destroyed.

    Also, silly question perhaps, but is the object you are destroying actually on the loader layout or on another layout?

  • Hello, I'm using a loader layout, when loading is complete (loadingprogress = 1) I destroy an object but it seems to have no effect.

    I mean, can not you destroy objects in a loader layout?

    There is no information here https://www.scirra.com/tutorials/318/how-to-use-loader-layouts-to-make-custom-loading-screens

    You can destroy an object on a loader layout... Even with that condition...

    I honestly don't know what you really mean but destroying an object on a loader layout on loading completed is kind of unusual or unnecessary.

    What are you actually trying to achieve?

  • Do you have any other actions running on the loading is complete event, e.g. go to layout? If so test by commenting those additional actions out and just run the "loading is complete" event and "destroy object" action to check that those actions aren't preventing the object being destroyed.

    Also, silly question perhaps, but is the object you are destroying actually on the loader layout or on another layout?

    > Hello, I'm using a loader layout, when loading is complete (loadingprogress = 1) I destroy an object but it seems to have no effect.

    >

    > I mean, can not you destroy objects in a loader layout?

    >

    > There is no information here https://www.scirra.com/tutorials/318/how-to-use-loader-layouts-to-make-custom-loading-screens

    >

    You can destroy an object on a loader layout... Even with that condition...

    I honestly don't know what you really mean but destroying an object on a loader layout on loading completed is kind of unusual or unnecessary.

    What are you actually trying to achieve?

    The object belongs to the load layout.

    When the load ends, only the "go to layout" action is executed, the other actions do nothing !, I can not destroy objects, I can not make them invisible, etc ...

    What I want to do is leave a few seconds the layout in black completely.

    Only the ramLoading object exists in the loader layout.

    But I can not destroy it, or make it invisible or put the X to -1000.

  • If I remember correctly there is a trigger for when the loading is completed. Try using that instead of the loadingprogress = 1 condition.

  • If I remember correctly there is a trigger for when the loading is completed. Try using that instead of the loadingprogress = 1 condition.

    That works well on a minimal project but in my project does not work! I do not understand.

    Just what happens is that the only action that is executed is "go to layout" the other actions are not executed in my project.

  • Then your best bet would be to fire a bug report about this and contact Ashley with your .capx.

  • > If I remember correctly there is a trigger for when the loading is completed. Try using that instead of the loadingprogress = 1 condition.

    >

    That works well on a minimal project but in my project does not work! I do not understand.

    Just what happens is that the only action that is executed is "go to layout" the other actions are not executed in my project.

    I tried both conditions... I recreated your events and as far as i tested, there were no bugs.

    Are you sure your picking of object is right? There might be multiple ramLoading in the layout. And maybe the other object got destroyed you might just not know.

  • >

    > > If I remember correctly there is a trigger for when the loading is completed. Try using that instead of the loadingprogress = 1 condition.

    > >

    >

    > That works well on a minimal project but in my project does not work! I do not understand.

    >

    > Just what happens is that the only action that is executed is "go to layout" the other actions are not executed in my project.

    >

    I tried both conditions... I recreated your events and as far as i tested, there were no bugs.

    Are you sure your picking of object is right? There might be multiple ramLoading in the layout. And maybe the other object got destroyed you might not just know.

    My project is quite large, I will minimize it and try the loader layout to a minimum to see what is causing that behavior. I will solve this thread of conversation.

  • Mirlas - Okay. Good luck. I hope you find the cause and fix of your problem.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Solved case, this "wait" causes the "destroy" action below to fail.

    https://dl.dropboxusercontent.com/u/60803633/testLoaderLayout.capx

  • Just use "on start of layout", isn't it the same? It will run in the first tick..

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)
Similar Topics Posts Views Last Post
Unread hot topic
167 14,512
DMT2005's avatar
DMT2005
Unread hot topic
132 29,605
chadorireborn's avatar
chadorireborn
Unread hot topic
90 77,102
leonhard's avatar
leonhard