0 Favourites

Sound BUG found and recorded

  • Problem Description

    ____ The bug creates a 0.005 second gap of no audio. The bug may be within audio-looping function or within the playback rate function. Either way it seems more likely to happen when there are more sprites added to the scene eg. 300-1000 64x64px sprites. ____

    Attach a Capx

    ____ Capx is attached. ____

    Description of Capx

    ____ This Capx plays one sound file that is perfectly loopable, on the smallest scale the start and end both start at the zero-point, (I used a program called EndlessWAV to make it perfectly loopable).

    By clicking on the "+" and "-" sprites you can change the Playback_Rate (pitch) of the looping sound.

    You can also change the volume of the sound with the second set of "+" and "-" sprites. ____

    Steps to Reproduce Bug

    • Step 1 - Overload the scene by populating it with more sprites, or many animated sprites.
    • Step 2 - Lower and Raise the playback rate and hear for any Noises, pops and clicks.
    • Step 3 - Record the PC speaker "Stereo-Mix" output, and disable your microphone in the process.
    • Step 4 - Analyze the recording from the audio output of this CAPX.

    Observed Result

    ____ Most of the time the loop plays clearly and perfectly, but once every 5 or 10-seconds there are very noticable audio pops and clicks and little annoying noises. ____

    Expected Result

    ____ There is no reason why the audio shouldn't loop perfectly from layout start to end, without any pauses. I expect it to loop perfectly. ____

    Affected Browsers

    • Chrome: (YES)
    • FireFox: (YES)
    • Internet Explorer: (N/A)
    • NodeWebKit: (YES)
    • CocoonJS on Android: (YES)

    Operating System and Service Pack

    ____ Windows 7 (64-Bit) SP1 ____

    ____ Android 4.4 KitKat ____

    Construct 2 Version ID

    ____ Construct 2 r175 beta (64-bit)____

    Thank you, you guys rock!

  • I think audio playback should get highest (CPU) priority, even over sprites and visuals. Why? becos sound happens on a much smaller scale than the tick level, and even a 0.005-second gap in audio is easily heard as a popping noise sound. In other commercial games, even when they hang the visuals freeze but the music and sounds keep on playing perfectly, so that proves that audio gets (CPU) priority over graphics.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • There is nothing we could do to fix this: the browser generates the audio samples, not any Construct 2 code. You should file bugs with the affected browsers (crbug.com for Chrome and bugzilla.mozilla.org for Firefox). Closing as won't fix.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)