0 Favourites

Bug in Color tool in Sprite editor

  • Bug in Color tool in Sprite editor. I often create sprites with the sprite editor. Just colored boxes to use to spawn objects. Using the eye dropper I selected a transparency (in the main editor) by accident. It will no longer select or insert a chosen color onto the pallet. Both pallet boxes remain transparent in the color pallet tool.

    I can't replicate the issue because it's not in the game code. The problem exists no matter what project I open.

    Using latest stable version 184 (64 bit).

  • Can you explain exactly what you are doing, what is happening, and provide all the details required by the bug template please? Provide screenshots if it helps. I don't understand why you can't just type new values in to the color picker RGBA values either, have you tried that?

  • Sounds like the color picker set the alpha control in the rgb values to 0.

  • Problem Description

    Bug in Color tool in Sprite editor. I often create sprites with the sprite editor. Just colored boxes to use to spawn objects. Using the eye dropper I selected a transparency (in the main editor) by accident. It will no longer select or insert a chosen color onto the pallet. Both pallet boxes remain transparent in the color pallet tool.

    Attach a Capx

    There's nothing to attach. I can't replicate the issue because it's not in the game code. The problem exists no matter what project I open. It's in the sprite editor.

    Description of Capx

    I specifically remember that, with the eye dropper, I clicked on the main sprite editor area, which was empty.

    The 2 color boxes, one had color, went transparent, as the main editor.

    When I tried to select a color in the pallet , it refuses to add the color to the boxes in the color pallet. It just stays transparent.

    Observed Result

    It doesn't matter now if I select a different project or start another new project, it refuses to respond to any color selection in the color pallet. Even if I open a sprite image, it still does not respond to color selection.

    Expected Result

    I expect the color pallet to take the selected color and make it available to the paint bucket and other drawing tools.

    Operating System and Service Pack

    I'm running Windows 8.1.

    Construct 2 Version ID

    184 (64-bit)

    I attached 2 screen shots, one of the editor, and one of the pallet.

    Hope this is clear and concise enough. I can't think of anything else I can try.

  • I also experience this. I think what I do is use the color picker on another sprite.

  • I tried that too. Are you running Windows 8.1 too?

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • You can change the alpha value back to 255.

  • Yeah, your screenshot shows the alpha is set to 1. It sounds like it is working correctly and you just need to set the alpha back to 255.

  • Thanks. That did it. I actually tried changing value but, not to 255. Once I put in 255, it worked.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)
Similar Topics Posts Views Last Post
Unread hot topic
0 Favourites
Sprite Font Generator - v3
368 112,316
RetroDaddy's avatar
RetroDaddy
Unread hot topic
86 28,711
St4rDu57's avatar
St4rDu57
Unread hot topic
153 104,445
DravenX's avatar
DravenX