[plugin] jsPDF

  • JohnnySheffield

    your plugin is in conflict with the filesaver plugin from Pode as soon as i save the pdf.

    All works well, until i ad the filesaver plugin to my project.

    And for my project i need them both.

    hope u can fix it.

  • Hello, Thank you for your plugin it is very helpful for me to create pdfs.

    But I have one issue with increasing the table width. I increased the following key property as well as html table width.

    margins = {...., width : 1500};

    But the table width seems to be same for whatever value given. Please help me increasing the table width as I have large no.of columns to be displayed. Note that, I generate pdfs using landscape view and a4 size (agreed options).

    Another issue is that how to break words in headers in pdf file?

    Thanks in advance.

  • Savvy001

    Unfortunately, i have some bad news; the problem lies in the libraries used by Filesaver and jsPDF. As it seems, one of the dependencies for jsPDF is actually the filesaver.js used by pode's plugin and conflict arises on global namespace when working with URL variable.

    I tried to work around it; in C2 event sheet as well with adapting filesaver.js but with no luck.

    julie12

    I'm not sure what do you mean with "increasing the table width. I increased the following key property as well as html table width.".

    Are you trying to render .html inside .pdf file using this plugin? The jsPDF library supports this functionality, but i have not managed to implement it in this plugin.

  • I'm having a problem exporting for node webkit. When I try to save this message appears:

    Uncaught node.js Error

    TypeError: undefined is not a function

    at l.vm (file:///C:/Users/Vini/AppData/Local/Temp/nw8708_29817/c2runtime.js:364:450)

    at g.Pl (file:///C:/Users/Vini/AppData/Local/Temp/nw8708_29817/c2runtime.js:197:159)

    at a.tj (file:///C:/Users/Vini/AppData/Local/Temp/nw8708_29817/c2runtime.js:190:126)

    at a.$a (file:///C:/Users/Vini/AppData/Local/Temp/nw8708_29817/c2runtime.js:189:308)

    at l.fr (file:///C:/Users/Vini/AppData/Local/Temp/nw8708_29817/c2runtime.js:124:210)

    at l.cm (file:///C:/Users/Vini/AppData/Local/Temp/nw8708_29817/c2runtime.js:123:304)

    at l.Vo (file:///C:/Users/Vini/AppData/Local/Temp/nw8708_29817/c2runtime.js:122:376)

    at l.trigger (file:///C:/Users/Vini/AppData/Local/Temp/nw8708_29817/c2runtime.js:122:281)

    at m.On (file:///C:/Users/Vini/AppData/Local/Temp/nw8708_29817/c2runtime.js:346:24)

    at d.Vf (file:///C:/Users/Vini/AppData/Local/Temp/nw8708_29817/c2runtime.js:357:64)

    What i'm doing wrong since it worked on the construct preview?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Sounds like problems with the minifier, try exporting with the option unticked

  • sidyo Noncentz705

    IIRC, the minification with this plugin is not currently supported... Did exporting with minifier turned off helped with problems?

  • sidyo

    Thanks to the great Noncentz705, minification is now supported. My preliminary tests on nodewebkit show everything looks ok. Also, i've put the repo public and you can find it here: http://git.machina.hr/c2plugins/jspdf

  • i copy plugin to plugins and behaviors folder too, and i cant open your pdf example because plugin is not installed. How can i install it?

  • it is possible to open pdf files with this plugin?

  • This is great plugin, just starting to use in my project

    However I installed a Google web font (Vollkorn italic, working fine in C2) but when trying to use the same font in the jsPDF Set font action, it comes with "font not supported" error. Does it mean that even though the C2 uses it, jsPDF only supports "native" C2 fonts??

    Thank you

  • The developer of this plugin should be aware of this http://stackoverflow.com/questions/2690 ... s-in-jspdf I tried to add it but it kept throwing javascript errors

  • ...this entry can be deleted

  • Hi, I am using this plugin and it works a dream with just about all the features I need. Except one...

    When the pdf is generated, by default it gives an option to open/save through Adobe Reader/Acrobat, however it seem to "overwrite" my default setting in Adobe to open in "fit page / fit height" and opens instead in "fit width". This creates a huge problem for me since resolution I have is good for 1 page view and A4 print but not for "fit width" preview. Is there a way that this can be changed to "fit height" within the jsPDF code?

  • It seems the plugin link is broken - I get a connection timeout error.

    Is it possible for you to fix the link? That would be great

  • download link not work

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)