[Effect] Fire Flames

  • Ported from shadertoy:

    https://www.shadertoy.com/view/4slXz2

    Screenshot:

    Added more than 25 Parameters you can adjust:

    Note: Remember to use negative values for fun results! <img src="{SMILIES_PATH}/icon_e_wink.gif" alt=";)" title="Wink">

    Added additional things like the option to enable/disable each flame individualy and a final blend.

    Download Effects and Demo:

    https://dl.dropboxusercontent.com/u/659 ... e/fire.rar

    Live Demo:

    https://dl.dropboxusercontent.com/u/659 ... index.html

  • Taken from your demo, it looks different than your screenshot, is that normal?

  • This is how looks in my preview, but when i run looks like in my screnshots.

    The effect runs well on Firefox, Chrome and NW.js on Opera appears a blue square.

    You said this is taken from my demo, but from where? The live demo? Your Construct2 preview or runnig? What browser,etc...

    I'm using the Beta 209 of Construct2.

    When you runs the effects appears ok? ¿?

    Edit: This is a videos that how looks on firefox: https://instagram.com/p/5IDK4xAL3i/

    (Sorry for the low quality)

  • matriax

    Sorry for late reply, I'm using shader version is AMD Radeon HD 6550D Direct3D11 vs_5_0 ps_5_0

    Also at shadertoy, it looks different such as cartoon flames, what's version yours?

  • The fireflames effects is the same from shadertoy, i made also the variations. Looks weird on Direct3D but good when WebGL is used, ¿Why? I don't know, i'm new on shaders , Maybe Gigatron can explain what is happen here or look the code and solve it.

    As i said in my C2 preview , i mean in the C2 layout, looks a bit weird(Direct3d is used), exactly that you screenshot, but when the effect runs on C2 using NW.js or in the browsers Firefox/Chorme that uses WebGL appears perfectly.

    So, when DIrect3D is used looks like you, and when WebGL is used looks like my screenshot.

    Also i not understad why in your case are using Direct3D, how are you getting this? NW.js? Browser? Mobile?... Also, have you tested to export to desktop o see with NW.js or chrome, firefox etc...? In all is the same?

  • Yes I am here ; ok for unknown reason some ST shaders are not running on some GFX cards ...In other word some

    gfx cards emulate shaders a bit differently ..

    In this case : replace in triangle function : for ATI Cards like me:

    btw: i am not an expert on shaders

    float triangle(float t){
    		
    	//return (fract(t)-flamesP) * sign(fract(t / 2.0)-.9);     <---- replace this line 
    	return (fract(t)-.5) * sign(fract(t)-.5);                            <---- by this one
    
    }[/code:2wk7qmif]
    [img="http://gigatron3k.free.fr/html5/C2/FX/fire.png"]
    Running on firefox 
    Regards
  • Gigatron

    So you have to add 2 versions of the effect and define which Card is used in order to define the plugin to use?

  • Don't know , this fx done by matriax..

    He can easily add a variable for selecting cards...

    If(cards==0.0) then ....

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Wow great! Gigatron!

    Worked! Now with the line change both version works <img src="{SMILIES_PATH}/icon_e_biggrin.gif" alt=":D" title="Very Happy">

    Seems was my fault on the FlamesP variable, sorry! :S , I go to upload the new version, one moment!

    Link updated: https://dl.dropboxusercontent.com/u/659 ... e/fire.rar! Please Joannesalfa test it now ¿Works correct?.

  • matriax

    That's perfect same... but not at all, for some unknown reason, It cannot run shader in Chrome, besides Firefox and NW.js worked very fine

    Console says... Using Canvas 2D renderer WTF???

    Edit: Nevermind lol, my chrome just crashed webGL because I was using too many shaders each window and set canvas renderer, this is not errror, it works perfect in chrome, thanks!

  • Thanks for the feedback! About Chrome mmm, i thought had a more advance WebGL support than Firefox.

    In my case Firefox(39.0), Chrome(43.0) and NW,js works without problems, in Opera(12.7) not runs that is one of the browsers with less WebGL capabilities.

    Edit: Ah! I see! Works also on Chrome, Perfect then!

  • Cool effect! I'd love to tinker with it but when I try to preview I'm getting this message:

    What should I do to get this running?

    EDIT: I should add that I'm using the latest version of chrome and that it doesn't seem to matter which Browser I choose in the previews settings.

  • Uh no idea sorry. You can't see the efect even in chrome/firefox?

    The live version works for you?:

    https://dl.dropboxusercontent.com/u/659 ... index.html

    You tried to create a blank document, add a sprite and choose the Fire Effect flames? If not try that to see if works, some people had problems with the .capx but creating they a new document,etc.. works fine.

  • Cool effect! I'd love to tinker with it but when I try to preview I'm getting this message:

    What should I do to get this running?

    EDIT: I should add that I'm using the latest version of chrome and that it doesn't seem to matter which Browser I choose in the previews settings.

    Have you installed NW.js?

    This has been a separate install for quite a while now. It can be downloaded and installed from HERE.

  • Uh no idea sorry. You can't see the efect even in chrome/firefox?

    The live version works for you?:

    https://dl.dropboxusercontent.com/u/659 ... index.html

    You tried to create a blank document, add a sprite and choose the Fire Effect flames? If not try that to see if works, some people had problems with the .capx but creating they a new document,etc.. works fine.

    Yeah, it would work in the demo, just not from the capx. When I try it on a new layout the error doesn't come up but it also doesn't display the effect. Thanks for the reply,

    @zenox98 I tried downloading it but I must not have gotten the right thing. Thanks for the link and your help!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)