[PLUGIN] Spilgames HTML5 Game API

  • Why not just use the new plugin that Spil created for us that I posted a few posts up?

  • This is the latest one i have from them. This is the latest one i have from them. h_t_t_ps://www.dropbox.com/s/zmt7zas6ojnwwnv/pix_spilgames1.3beta.c2addon?dl=0

    Mm, is it? I used it

  • PixelRebirth, thanks a lot for this plugin, great job!

    I recently integrated Spil API into my game and found a small problem with the "Submit Awards":

    runtime.js

        Acts.prototype.awardSubmit = function (type) {
            if (self.apiReady &&
                typeof self.API! == 'undefined' &&
                typeof self.API ["Award"]! == 'undefined' &&
                typeof self.API ["Award"] ["submit"] === 'function') {
                self.API ["Award"] ["submit"] ({award: type});
            }
        };[/code:2no18w6b]
    this code gives a negative message "Award submitted with no value" in Test Tool.
    
    I use a usual [b]Browser - Execute javascript[/b]:
    [code:2no18w6b]"Var award = {award: 'award5'};
       
        // Submit the player's score
        GameAPI.Award.submit (award); "[/code:2no18w6b]
    and it works fine but I don't understand why the similar code doesn't work into [b]runtime.js[/b], nevertheless "submit Score" works great.
    
    [b]PixelRebirth[/b], in what could be the problem?
    

    I haven't been involved with the development of this plugin for a while now and "submit Score" as well as "submit Awards" are functionalities that have been introduced more recently. I'm afraid you might have to consult with Spilgames about any issues that come up.

    I'm not sure they have someone active here on the forums, so be sure to check out their documentation or contact their support directly.

  • Ok, I have a totally strange issue...

    My game failed Spilgames' QA (few times already!) since sometimes 'more games' button doesn't work and/or logo doesn't appear etc.

    What I have found out is that SpilgamesAPI sometimes loads, sometimes - not. When it loads, I get everything working fine - logo, more games link, ads in the pause... Test tool shows green. But, in some 30% of cases, API fails to load. This is the case even when I make a dummy project, where ony SpilAPI is included, and one event checking if SpilAPI is loaded.

    I have used the latest SpilgamesAPI addon - pix_spilgames1.3beta.c2addon

    Did anyone stumble upon similar problem? I guess that the issue might be in the index.html file, specifically in the part where spil.js is invoked.

  • pix_spilgames1.3beta.c2addon i used it,but have a javescript error,can not use it...the 1.1and 1.2 beta can use ...anybody know this reason?

  • Try using this in your index.html file <script type="text/javascript" src="http://cdn.gameplayer.io/api/js/game.js"></script> instead of <script src="spilapi.js"></script>

    Otherwise you can try reaching out to support. Mario Gesteira was the one helping me that updated the plugin. The one I link via my dropbox is the latest one I have that I used for my game about 2 months ago.

    Support email.

  • Thanks, ArcadEd. That's exactly what Mario answered me. I've implemented the fix, the issue is gone now, and I'm waiting for another round of QA.

  • Thanks, ArcadEd. That's exactly what Mario answered me. I've implemented the fix, the issue is gone now, and I'm waiting for another round of QA.

    Hi,Could you tell me how to use this plugin 1.3beta? I test in C2 206version,but Always can not run,in c2 bugtest mode is say javescript error

    and i upload it ,is always black screen,

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I would contact support. It should be as simple as including the plugin and created the events and actions you need. It shouldn't cause a java error.

  • I would contact support. It should be as simple as including the plugin and created the events and actions you need. It shouldn't cause a java error.

    thank for help,i just included the plugin,have not add any event,i will add event test again,thank very much!!

  • This was an amazing plugin, keep up the great work.

  • if you get an error while exporting - remove the extra brace in runtime.js (in 1.3beta)

    self.API["Score"]["submit"](

    {

    value);

    Acts.prototype.scoreSubmit = function(value) {
            if (self.apiReady &&
                typeof self.API !== 'undefined' &&
                typeof self.API["Score"] !== 'undefined' &&
                typeof self.API["Score"]["submit"] === 'function') {
                self.API["Score"]["submit"]({value);
            }
        };[/code:2ovfdd9n]
  • > Thanks, ArcadEd. That's exactly what Mario answered me. I've implemented the fix, the issue is gone now, and I'm waiting for another round of QA.

    >

    Hi,Could you tell me how to use this plugin 1.3beta? I test in C2 206version,but Always can not run,in c2 bugtest mode is say javescript error

    and i upload it ,is always black screen,

    Did you fix it? im having the same error. Included the plugin and it goes black.

  • Hi! sorry for my bad english, we are from Chile. This plugin has worked really fine for us. There is one thing we don't know how to implement; publicity in our main menu. We are talking about an embedded ad, something that coexists with the rest of the buttons from the menu. Does anybody have made something like this or has a clue about it? Thanks a lot in advance.

  • PixelRebirth download link broken. please upload again

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)