[Behavior] 8directionMP, platformMP

  • Seems to be working beautifully now. And yeah, not sure why I was adding extra controls instead of the main method. Thanks so much rex, your support is a lifesaver. <img src="smileys/smiley1.gif" border="0" align="middle" />

  • Sorry guys, the reference wasn't informing me that you were talking about me. :D

    I will take a look at the trigger code. For some reason, I thought I did combine these.

  • Wastrel

    Thanks. I'm glad that our plugins can work together. It's cool.

  • Well, turns out the previous bug wasn't actually fixed. The bug I described only occurs when you change an extra control, not a default control -- I THOUGHT it was fixed because I stopped using extra controls in favor of default controls, as you advised. Now that I need to use extra controls again, I ran into the same problem. <img src="smileys/smiley6.gif" border="0" align="middle" />

    Sorry to keep troubling you rex, but could you take another look? You can use the example capx I posted on the previous page to see the problem, since it still doesn't work.

  • SullyTheStrange

    Sorry, I can not catch your problem.

    I test this issue by using previous capx

    dl.dropbox.com/u/5779181/test_platformMP.capx

    It looks fine.

    (test in firefox)

  • The problem is with the "extra control". In the one you just posted, it's replacing the default controls and it works, but if you're using extra controls, it'll freeze.

    db.tt/M6uldR3X

    This one I posted on the other page uses extra controls. I know you SHOULD replace default controls, but in my actual project, I'm using them for something else, so don't scold me too much. <img src="smileys/smiley17.gif" border="0" align="middle" />

  • SullyTheStrange

    I test this capx and look great.

    I has updated platformMP again to ensure that we are using the same code.

  • I redownloaded it and it does appear to be working now. Sorry for the misunderstanding! <img src="smileys/smiley5.gif" border="0" align="middle" />

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I'm back yet again, this time with a question: is there any way to set controls to mouse buttons? I can't find out whether or not mouse buttons use scan codes the same way other keys do, so that seems to be out of the question. And PlatformMP can't set a control to any mouse button the usual way. Is there a simple way to make it work?

  • SullyTheStrange

    Sorry, 8directionMP and platformMP now only support keyboard.

  • Okie dokie, it's been a while, but I'm finally getting around to finishing the custom controls and I ran into what I HOPE is one final problem. I reproduced it in this small capx:

    dl.dropbox.com/u/19702035/platmptrouble.capx

    It seems that when you try to change an extra control's keycode, it sometimes doesn't work. Here, at the start of layout, Jump is set to Space, Left is set to A, and Right is set to D. If you tap the H key, Jump changes to Shift, Left changes to D, and Right changes to A. It outputs text every time it detects an extra control being pressed, but after you press H and change the assigned keys, it doesn't work correctly anymore. "Left" will output like it should, but "Jump" still uses the old key and "Right" doesn't work no matter what you press.

    I know this is an old plugin and you're probably sick of looking at it, but could you find the time to help me out again? <img src="smileys/smiley1.gif" border="0" align="middle" />

  • SullyTheStrange

    Thanks for testing, I'll fix it latter.

  • Update:

    Update 8directionMP and platformMP following r79.4 and fix bugs, thank you

  • Very nice !

    Thanks <img src="smileys/smiley17.gif" border="0" align="middle" />

  • I will give up these two behavior. I might try to implement new one to replace them.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)