Spiders are not cooperating

This forum is currently in read-only mode.
  • Hi all,

    I recently (kind of) finished an enemy for a game i'm working on. All worked well and good until i added another one to the layout for testing. Now all enemies seem to react to events that are only supposed to affect one of them.

    At first i thought the problem was in the comparing of X position relative to the main character sprite, but i think i fixed that and the problem remains.

    What is supposed to happen is that when MC comes close to a spider, the spider will move towards the MC and bungee down when the MC is directly below it. If the MC is far away, the spider should return to its original X position. This works when there's only one spider.

    I would be very grateful if someone could tell me what i'm doing wrong and how to fix it.

  • You need some persuading power. Here, take this:

    <img src="http://www.pladvertisingspecialties.com/promotional_kitchen/promotional%20kitchen%20pics/fly%20swatter%20bsr1.jpg">

    Okay, sorry, currently I am unable to look at your cap, however I can tell that you're having issues with picking. You have to be aware which instances are being selected. I'm sure someone else can shed more light onto this while I wrestle with Windows 7 here...

  • Hi all,

    I recently (kind of) finished an enemy for a game i'm working on. All worked well and good until i added another one to the layout for testing. Now all enemies seem to react to events that are only supposed to affect one of them.

    At first i thought the problem was in the comparing of X position relative to the main character sprite, but i think i fixed that and the problem remains.

    What is supposed to happen is that when MC comes close to a spider, the spider will move towards the MC and bungee down when the MC is directly below it. If the MC is far away, the spider should return to its original X position. This works when there's only one spider.

    I would be very grateful if someone could tell me what i'm doing wrong and how to fix it.

    That's quite common. I don't remeber but i think you have to put them all in to one family and then in the events call that family insted of one object. Or you can try addin 'for each' ... not sure.

  • Just insert spider into family and then use family for everything. Like enemy(family's name) is over MC -> jump and NOT spider is over MC - > jump

    EDIT You have to insert enemy family into sprite 33 and then replace all sprite 33 conditions and actions with enemy group. Well the group can be any but enemy should fit this case.

  • Hmm, I did as you say and replaced all the conditions and actions, but the problem still remains

    Maybe i did something wrong, i'm confused to how putting things in a family would solve the problems.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • in family it wont just test all for that specific spider but checks spider that meets conditions and well when i tried that cap I didnt see any problems though I didnt test much cuz I had to go

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)