Python External Libraries w/ AI, Speech

This forum is currently in read-only mode.
From the Asset Store
Customizable speech bubble dialogue system! With this dialogue system, you can finally have speech bubbles in your game!
  • When i compile it and try to run the AIML exe, it says "WARNING: No match found for input: load aiml b" and anytime i try typing,

    This error means that you didn't copy the AIML files into your execution path. It has to have something to load! The aiml files are the which have to be unzipped in the same directory as your .cap or .exe.

    As far as getting PyGame to work with Construct just use this:

    This has the dependencies for Pygame. You will need to unzip the contents of the file into your Construct/Data/Python directory. You will need to check all of the .pyc files per the quickguide, but you can skip PodSixnet and other unrelated .pyc files. The other dependencies ( have to be redistributed with your game. Now you don't need ALL of those, but it will be up to you to decide which ones you need based on which parts of Pygame you use!

    I've used Pygame several times within Construct this way and it works just fine!

    Have fun in your Python studying!

  • Anyone know of a way to get them to work from a subfolder?

  • What do you mean by "them"? I haven't thought about running all of the dependencies from a subfolder, but there is no reason technically that it wouldn't work. If it doesn't work, then a feature needs to be added to Construct to specify subfolders for Python dependencies.

    Edit: Another thing I haven't tried, but should be possible (since you can do it in py2exe) is to embed all dependencies inside the executable. This includes the Dll and the pyd files. If you want to give it a shot copies those files into the Construct/Data/Python directory and then select them when exporting the .exe. Who knows it might work!

  • It is the python modules I meant and I think I've got it close to working... to start off it would give me an error saying there is no shutil to import. I read up about inserting a into the intended subfolder, that seems to get me a little further. But its saying I have to path module. I think thats supposed to be part of but I have the os in my subfolder which it seems to recognize but I still get the error. And I'm talking in circles out of frustration. Won't be able to work on it for a few days so if anyone figures that out let me know please.

  • You should never need to put any .py or .pyc dependencies in a subfolder or in the same folder as your executable. So things like os.pyc or shutil.pyc should ALWAYS be embedded in your executable. This is done right before you build your executable in Cosntruct.

    I don't think adding a helps with .pyd files (Python modules/dynamic link libraries). A is typically used to specify import and other info for other .py or .pyc files in the same directory.

    I won't have anytime to try this out this week, but if you haven't gotten it working by next weekend I might give it a shot to see what can be done with the .pyd files.

  • Push comes to shove I guess you could use Rojo's resource extractor.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • So things like os.pyc or shutil.pyc should ALWAYS be embedded in your executable.

    I was being an idiot. Opening up the subsection where you pick what goes in, but I missed some things. Btw, do you still have to place the python26.dll in the folder? I tried it out both ways and both seem to run.. I had my real python folder changed to a different name during the test.


Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)