Construct 0.99.3 broke graphics basically completely

This forum is currently in read-only mode.
  • Okay, so I'm at the verge of despair right now, because me and my friend have been working on an isometric game. Then we upgraded our Construct to 0.99.3, and coded quite a lot of things. Now we notice that it has horribly broken a lot of the graphics in the game:

    http://img13.imageshack.us/img13/9471/horrifying.png

    The walls have been positioned right next to each other with array paste. They're not the only thing that are broken: Other sprites appear horribly mangled and look disgusting.

    What on earth changed in 0.99 that basically completely broke rendering of sprites right next to each other? Is there any possible way to fix it, as this is quite a letdown for us, especially since the game is like 99% complete - we'd have to go back to about 80% were we to restart work from an earlier build.

    We've been using V-sync (which makes the game run at 60FPS for both of us) with Point sampling all the time. Setting the game to run at Unlimited fixes the problem for me, but not for my friend, and I wouldn't like to use this as a solution anyway.

    What on earth could we do? Putting "padding" walls behind the walls that are broken would only partially solve this - some sprites would still be mangled. Is there any possible way to make newer construct caps openable in older builds, particularly 0.98.9?

    This is seriously the worst thing that has happened to us with this project. Any kind of help would be appreciated.

  • Are you sure its not only in the layout editor? It's a known issue that the layout editor in 99.3 distorts the display of sprites. Also, why did you use 99.3? it's an unstable testing build....

    [quote:2ucc3fq6]We've been using V-sync (which makes the game run at 60FPS for both of us) with Point sampling all the time. Setting the game to run at Unlimited fixes the problem for me, but not for my friend, and I wouldn't like to use this as a solution anyway.

    I don't get how changing the frame rate could fix the problem, It might be some rendering glitch..

    are you sure it's not only in the layout editor?

    [quote:2ucc3fq6]Is there any possible way to make newer construct caps openable in older builds, particularly 0.98.9?

    I'm afraid not, newer builds use newer code which can't be recognized by the older builds.

    I'm pretty sure the next build has that layout sprite display glitch fixed, along with a few other things. Maybe wait till the next build to see if it changes anything. Don't make full projects in unstable builds!

  • That's an ingame capture, so it's certainly not only in the layout editor

    In any case, resizing those particular walls a bit solved the problem for them, but then there's the general funkiness of drawing that causes problems like this:

    http://img13.imageshack.us/img13/158/horrifying2.png

    Notice how the level edges are all dented (when they're supposed to be straight), it happens at certain locations, and when moving, the graphics constantly "flicker" between broken and non-broken for various things. At one point, the drawing of some sprites is broken, in another point, the drawing of other sprites is broken. This has happened at a minor scale so far with previous builds too, but in 0.99.3 it's more broken than ever.

    And I wanted to use the new features of 0.99.3 - in retrospect, I shouldn't have.

    EDIT: Also, basically all sprites use the alpha channel (in other words, they have antialiasing drawn to the sprites itself). Could this be part of the cause?

  • 1. are you using the window object?

    2. Are you using zooming?

    3. are you using any new 99.3 z features?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • 1. No, the game does not use the Window object at all.

    2. No, everything is 100% - no zooming is used anywhere.

    3. No, Z features are not in use.

    Basically it seems that the position and scale of sprites is flickering and changing constantly when moving for some reason, but why would scrolling cause this?

  • Try rounding the scrolling x and y to a whole number and see if that does anything to fix it.

  • if you scroll to a floating point position it might be causing it, i haven't tested float scrolling in the new rendering engine yet. try encopassing your scroll algorithm with int(my algorithm)

    edit: deadeye posted a sec before me..

  • Oh my god, round() did the trick. Everything works perfectly now!

    Except for my friend is still experiencing some weird rendering issues, like pictured below:

    http://img190.imageshack.us/img190/7717 ... eringw.png

    Any idea what could cause it? Surely float X/Y position of the sprite shouldn't be an issue?

  • Oh my god, round() did the trick. Everything works perfectly now!

    Hehe, you're welcome

    It seems to me that scrolling should automatically respect point filtering as well, though. There's not much reason to scroll at sub-pixel increments if your filter is set to point. Don't know how hard that would be to implement as a feature, though.

    Except for my friend is still experiencing some weird rendering issues, like pictured below:

    http://img190.imageshack.us/img190/7717 ... eringw.png

    Any idea what could cause it? Surely float X/Y position of the sprite shouldn't be an issue?

    Not sure what the issue is there because I'm not sure what the sprite is supposed to look like normally. It could be something like your friend may need to update his graphics card drivers.

    But if it's a matter of it going funny at the edges, and you want total compatibility with different kinds of graphics cards, then you should try leaving a 1px blank space around the outer edge of your sprite animation frames. I know, that's probably a lot of hassle at this point, but from here on out you can do this automatically when importing your sprite frames by holding Shift and clicking Crop in the image editor. Of course, there has to be a larger-than-1px space around your sprite already for the Shift+Crop trick to work

  • I think this is fixed in the next build, but I'm not sure what's causing it.

    What's with all the drama though? Why not just go back to 0.98.9 and carry on developing with that, in the meantime submitting a "latest unstable build broke my .cap" style bug report so the issue is known to the developers? If you imported your project to an unstable testing build, ignored the warnings in the build descriptions and did not make a backup, clicked "yes" when prompted to save your .cap in the newer build (because it prompts to tell you it no longer will be able to open in the older build the file came from) before even realising it had broken it, then found that your file is broken and you're stuck... would that not have maybe been... unwise?

  • Well, rounding the X&Y positions of visible sprites fixed the problem for him too, so floating positions of sprites seem to have caused the error for him.

    The sprites do have large blank space around them (larger than 1px) so this could be probably done but considering that the game has like 500 sprites it would indeed be quite a hassle - in any case, all the rendering problems are now fixed.

    Also, Ashley, I didn't notice that things were so broken because I was working in a layout with no scrolling - we only noticed it after lots of additions.

    In the end though everything is actually better than before since now even all the minor rendering flaws caused by floating point scrolling that were in the previous builds are gone, making the end result look better than before.

  • Heh, who needs floating points? "Ooh look at me, I have ten decimal places." Pff.

    Glad to hear everything is back on track

  • OK, well, I think you should read this. 'Unstable' builds are for testing only - it's not intended that people import their serious, important projects to unstable builds to continue them - precisely because of what happened to you! Things can be seriously broken in unstable builds (in fact, you should expect it), so the plan is everyone imports their .caps, gives it a quick run to check if everything's working, and if it's not, file a bug report. Then keep using the last stable build and only upgrade to the next stable build!

  • Yeah, I know. Then again, floating position scrolling was actually broken before as well: It just became worse in 0.99.3.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)