A beginner issue with animations...

This forum is currently in read-only mode.
  • Well I guess I'll start off with my .cap-

    http://www.mediafire.com/?2jcvrvzd9md

    After fiddling for a while, I seem to have fixed one problem, but a new one has arisen, and one still remains. For one, sometimes when "Guy" lands, he get's stuck in the falling animation, and seems to 'jitter' slightly. Secondly, when I press "right control" (the "attack1" key) while moving, Guy plays the animation "movingattack1", which is what I want to happen. But after the animation is done, he stays in the last frame of it until I let go of a movement key. how can I get him to go back to the standard "moving" animation?

    Controls are WASD for movement, and Right Control for attack. Any help is appreciated!

    Also, yes, the animations/sprites in general are pretty low-grade, I just want to get things working first. Then I'll polish those up.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I haven't gotten around do doing animations and I'm more of a newbie than you, but here's a uglyfix for the movingattack freeze until someone that works with animations can help you. What it does make it do the "moving" animation when no other animations are playing.

    http://w17.easy-share.com/1700930026.html

    Altlink:

    http://depositfiles.com/files/6616641

    BTW, your cap run at 15 FPS on my computer. I don't know if that's what you are going for. And when I watched the Guy animations in debug, for some reason it just doesn't seem like "movingattack" resets or ever finishes, so the on "movingattack" finishes event never triggers.

    The jittering, I believe is a new bug for this current build.

  • Well I fixed the hanging attack animation thing using your method, I just expanded upon it by adding a check for whether Guy is moving or not, and played the moving/standing animation accordingly. As for the jittering bug, there's not a fix or workaround available? Darn, guess I'll just wait till next release.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)