Problem changing starting layout [solved]

This forum is currently in read-only mode.
From the Asset Store
Simplistic hyper-casual game with nature elements. Tap to switch between the 4 elements and reach a better score.
  • Hi again!

    Lately I have had a problem with layouts that I don't really understand, and I wanted to ask if there is something weird with the programming, or if it's a bug.

    In my current project I have made a new "MainMenu" layout, which is supposed to be the menu screen that appears when the game loads up. The layout has only two things on it so far - a start game button and a quit button. The event sheet has no more than a "on click" event for each button, one that transport you to another layout, and one that quits the application.

    When running that layout alone it works perfectly fine as it should.

    But when I try to drag this MainMenu layout to the top of the list, so that it is the first layout to run when you select "Run all", the layout stops working. I can see the buttons, but nothing happens when I click any of them. If I drag it somewhere below again, it works normally on "Run layout".

    I tried it duplicating it in this example cap:

    Run the layout with the yellow block alone, and it will take you to the other layout as it is supposed to. Put it on top of the list and "Run all" - it stops working :S

    So... did I miss something? ^^;

    (In my original .cap I also get a strange problem with objects from a completely different layout (the original "layout 1") showing up on my main menu when I put it on top. And the objects aren't even global, or have any related events in the event sheet! :S )

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Copy the Mouse & Keyboard object from layout 1, and paste it to layout 2.

    Or make it global from the first layout.

  • So simple....

    I had already made the object global, so I thought I was safe there. But copying it over made it work.

    Thanks a lot *feels silly*

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)