[PLUGIN] Audiere Sound

This forum is currently in read-only mode.
  • While it played some ogg and wav files, I can't get it to work with mp3. Either complete silence or a short noise sound and then silence, that's all I get. Does it depend on any other library (lame, etc.)?

    EDIT: And what about 'set position' for sounds and peak/rms levels?

  • YES! YES! YE--

    Um... I mean... this is great! I can finally use music in my Construct games without having to bang my head against the computer!

  • I'd actually prefer to use this over Xaudio2, but I'm experiencing the same problem as tulamide: trying to play mp3s results in complete silence for some reason. <img src="smileys/smiley6.gif" border="0" align="middle" />

  • nice plugin!

  • I can play MP3s just fine.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • As can most.

    So it would be nice to find out, what is different to PixelRebirth's or my installation.

    XAudio2 works just fine, and all other applications using any kind of audio engine work fine, too (e.g. Audacity, Wavosaur, Reaper, Flash, Shockwave, Firefox Embedded, etc.)

    I guess, we won't find out.

  • What format are you saving your MP3s as? I used Layer-3 ACM.

  • I suspect it's an issue with the Audiere library itself. It uses directsound as a backend so maybe the issue is with newer versions of windows.

  • This plugin has a conditions "autoplay" like in XAudio2??

  • Thank you for bringing Audiere to Construct. This is great! It seems way more flexible and more intuitively set up than the default XAudio2 plugin. Plus, I don't run into weird "leftover" buffer glitches when interrupting channels and playing new ones (and thank god for not having to mess about with channels in the first place). :p

    A question: I'm running into a very odd problem with setting the volume. If I add any value of 1 and below to the music's volume every tick (for a fade-in effect), the volume remains unchanged in value. Adding exactly 1.000001 to the volume per tick gets it to 31, where it mysteriously stops despite repeated addition, and adding 1.000002 per tick gets it to 63, where it similarly stops. I'm setting the volume this way: Audiere.GetMasterVolume+1.000002

    Another example is: if you set volume to N, then the plugin will return that the volume was set to N-1, unless N is greater than approximately 96, in which case it will just return N. This sort of strange behavior makes me think that there are some strange math and/or datatype related hangups about the process used to convert the 0~100 volume value to decibels... or maybe the problem is with only the function used to return volume value?

    Anyway, um... it would be totally super if you could look into this! I noticed that you stopped paying attention months ago, but I'd like to use this plugin if I possibly can. :p

    This plugin has a conditions "autoplay" like in XAudio2??

    Repeated sounds overlap each other in duration, so I assume that sounds are "autoplayed" by default.

  • I just released 1.4 on the first post. I switched to using a higher precision floating point number type so most of those rounding errors should be eliminated.

  • I just released 1.4 on the first post. I switched to using a higher precision floating point number type so most of those rounding errors should be eliminated.

    Ah, thanks for looking at it! I just tested it out and... well, it's mostly fixed, like you said. :p

    Adding exactly 1 per tick makes the volume go up to and stop at 28 this time, but setting volume seems to work now. Adding values lower than 1 (e.g. with TimeDelta) is still, I'm guessing, out of the question, but I suppose that's easily circumvented by setting volume only every N milliseconds.

    Also, how is the limiter (or equivalent) set up within this plugin? Is there even a limiter? I'm sort of detecting that there's no automatic volume normalizing (a good thing, in my opinion), but I'm wondering if I still have a ceiling.

  • The Audiere library stores it's volume in a "float" (32 bit floating point number) which only keeps track of about 7 significant digits. I switched my code to do calculations with "double" (64 bit floating point number) which keeps track of about 16 significant digits. But after calculation the value is rounded to a "float", so adding a very low number will have no affect. I'll have to come up with another solution.

    In the mean time you can fade volume with a time expression:

    clamp(((timer-start_time)/(second_for_fade*10), 0, 100)

    There is no limiter that I know of. The plugin for the most part is just a wrapper for the Audiere library.

  • Ah. Well, until then, either the time expression or the every-x-milliseconds thing will work just fine. :)

    Fabulous. Thank you.

  • Nice plugin. I've been switching to it to get away from xaudio2 due to the crash bugs on layout changes. Mostly like it better anyways, but one concern~

    Is there any easy way to just murder all music channels like you can all sound channels? It'd be nice to not have to babysit all my music channels super carefully!

    I got some plans to make this a little less cumbersome, but again, it would be nice. I find it weird the option is there for sounds but not for music.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)