With version 157 stable, exported debug apk's are refused. [Solved (I think?)]

  • After having updated Construct 3 to version 157 stable, debug apk's are denied installation on android devices with a "unknown publisher" msg. Second time I try it just says "installation failed". There was no such problem in 156.2 and I haven't made any changes other than pure game logic in the game.

    Are Scirra aware of the problem or do I have to make a bug report?

    Thanks!

    edit:

    I did some more googling and it seems like the thing called "Google Play Protect" was involved.

    Found this that helped me get around it: support.mobile-tracker-free.com/hc/en-us/articles/360005346953-How-to-disable-Google-Play-Protect-

    However installing debug apk's made with C3 versions prior to 157 stable works without disabling Google Play Protect.

  • Hello, I had the same problem today, do not modify anything in my project, just add some comments between lines, after exporting my apk debug it did not work on my android device, however after disabling google play protect, even so it did not work correctly, but running my application in the browser I decided to open the google chrome console, I discovered that an error related to Ads pluging appeared, I decided to delete all the instances of that plugin to try again and after exporting an apk again debug, it worked correctly on my device.

    I find it a bit strange since yesterday I did not have that problem with pluging, but today after the update I failed my app without adding any extra code, just a few comments.

  • Rejected by Amazon for blank screen at startup (Fire 2017 HD8 and HD10). Tested on my Kindle Fire 2017, and screen gets blank for cc 5 seconds, loader shows at 98& (little late I would say). After that all works fine.

    Just in case someone care to fix it ...

  • TechBoxNorth I can't say I've experienced this problem with debug APKs. But I have seen it previously when installing signed release builds locally. I assumed this was because I was installing release builds from a source other than Google Play.

    If Play protect decides an app is something "suspicious" then it will show you a dialog during installation. If you pick the wrong option on the dialog your app ends up on a blacklist on the device for awhile, so installing will silently fail after that. The default option is to block the app.

    There is also a global blacklist for applications which will block installation on any device, you have to appeal to Google to get this revoked.

    If this to a change we have made it is not one we know of. There have been a number of modifications for that release, including a fairly major breaking change to the Mobile Advert plugin which we have talked about here.

    It's difficult to tell if the joinner was having exactly the same issue, it sounds to not be related to Google Play Protect.

    iggyplusceci your problem sounds completely unrelated to this. If you think there is a bug and have a replication then feel free to file an issue on our bug tracker. Mentioning a problem in passing on the forum is unlikely to get the attention of the construct team, and it's not enough for us to actually investigate a problem. I'm inclined to say that the Amazon QA team would not have rejected your application for being slow to start. There's a few reasons I can think of which could explain why the game did not load for them, but it's purely speculation.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I've confirmed that a debug build of my Mobile Advert test project created in r157 installs correctly on a device.

  • No it does not! New build is garbage... Debug build works on some phones and not on others. Published apps are freezing at startup. Test it better and not only on your last model updated device.

  • iggyplusceci we're happy to investigate issues, but we need to know the scenario. Without that we're in the dark about whatever the problem is.

    We test on multiple devices, of differing ages and Android versions. But issues are often related to specific projects, devices, plugins or combinations of plugins. It's pretty much impossible to test every situation, so we cover the common ones and rely on user bug reports and the beta cycle to root out the rest.

    If you have a specific problem you are aware of please file a bug report, and we will investigate it.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)