A way to run an older stable version of construct 3 in the desktop build?

  • I've encountered an issue with my project in the latest stable that broke a fundamental part of my project, in a way I don't know how to reconstruct into a working state.

    The problem is, I made backups of my project before updating to stable in-case, only to discover that the web version of Construct 3 doesn't accept project folder save types. So I'm left with a broken project, because if I try to save it as a compatible individual file, then it tells me it has saved in a newer version and it won't load it.

    Additionally it has made trying to resolve this issue here - github.com/Scirra/Construct-3-bugs/issues/2929 - difficult, and that is now closed but I can't formulate a better opinion or try and tackle my case from a different angle because the project that was working essentially is no longer accessible, even though I made backups of it to prepare for potential problems.

    Would be very grateful if the desktop build could access older construct 3 versions.

    Tagged:

  • sounds like your issue is unrelated to r148

    but you can recreate the part that is NOT working in editor.construct.net/r142 and see if that fixes it.

    Not sure how big your project is.. but open one tab in r/142 and another tab in r/148 and copy paste over all your objects and events...

    EDIT: oh nevermind, it won't let you cut/paste between tabs right?

  • sounds like your issue is unrelated to r148

    but you can recreate the part that is NOT working in editor.construct.net/r142 and see if that fixes it.

    Not sure how big your project is.. but open one tab in r/142 and another tab in r/148 and copy paste over all your objects and events...

    EDIT: oh nevermind, it won't let you cut/paste between tabs right?

    As I have tried to explain, though not being able to re-open my project in the previous stable has left me unable to demonstrate, absolutely all I did was update my editor version, play it, and see it broken.

    Recreating a small demonstration of it in r142 I find it not working, however it was working in my project-but I can't understand how to recreate the same circumstances of it or what allowed it to work, and I can no longer see it working to even get a grasp of it.

    Additionally my project is saved in folder format on the desktop version.

    It's not large, but it's not small enough that I can just copy and paste it (I was surprised to see I could copy/paste from my desktop version to the browser at all), but there's various complexities and you can't copy/paste things like families which is where a lot of the required data is.

  • Swift, you may be able to fix your project files yourself. First I open Chrome dev tools before opening a project, to see the actual errors. Then, you may be able to narrow it down to a problem in your .c3p project file or other files. I’ve edited these before to recover from beta build bugs and other problems.

  • if you can't recreate the same behavior in /r142 then I think you need to maybe investigate what you recently changed.

    I know its easy to want to blame an update, and I myself have done it a bunch of times. But its a common occurrence since Construct is updated so often..

    Recently I "updated" (btw updating is the wrong term - since nothing actually gets updated, you instead just start going to a different link) to r/148 and I happened to be testing something in a game I've been working on. I noticed the gamepad was not responding properly. I was going crazy trying to figure it out. I assumed something broke in Chrome or in r/148. Turns out, I had a crash a few days before because of a while loop and I ended up losing data. Ashley told me to use Worker mode to prevent crashes from ruining my editor session. But failed to mention that Worker doesn't respond the same at all. So when I turned Worker off, everything works.

    So you may need to research changes you have made in your game recently and back track from there...

  • Thanks for another response, but to further re-iterate, my project was at the status of 'complete'. All I was doing was having a few people play the final version to get a feel for it and see if I might have needed to tweak the tutorial or add any extra information to descriptions.

    I wasn't changing anything.

    I understand 'update' isn't the right term necessarily, however the fact is I can no longer reach the previous stable release in the desktop version-the only version compatible with my project folder save, and saving it newly into a single file forces a version restriction on it so I can't load it in older browser versions you can still access.

    So all I'm left with now even after backups and carefully approaching the new stable release is a complete game that is broken, which is pretty disappointing for me after my relative enjoyment working on it in this engine and being happy with where it was.

    EDIT: To further note, opening even older backups from 26th of the 4th are broken in the current version.

  • just add a Wait 0 before you set the density which will wait for it to get to the end of the sheet.

    drive.google.com/open

    (this uses r/148)

  • btw not having your objects in your Layout will cause a big lag spike when you go to do a 'Create' since it will need to load them into memory after the layout has already started.

    I suggest adding in the objects and Destroying them on Start of Layout, just so they are already loaded into memory.

  • just add a Wait 0 before you set the density which will wait for it to get to the end of the sheet.

    https://drive.google.com/open?id=1RAQFUdiHbmIRof0enjOL7Pku_iupLRfw

    (this uses r/148)

    Incredibly appreciative of your effort to try and find a solution for this, however the reason that works is only because you've enabled physics before setting the density.

    My issue is in my project I need to set the parameters before physics is enabled. A wait 0 is practically muscle memory for me now as a first attempt to fix something, it didn't work at any point I tried in the latest stable.

    Thanks for the tip of having objects in the layout, however because that has caused me so many issues in past projects I prefer now to just have a storage layout I keep the objects and their default settings in instead, even if it's not as efficient.

    Really all I want to do is be able to give my project a final polish in the last desktop stable version it was working in to release it, I don't want to have to try and re-engineer it and find new workarounds and retest and tweak everything all over again.

    Here's a set of comparison video's.

    This first one is the last stable release, that I uploaded to my site prior to r148 and was just waiting for feedback on.

    youtube.com/watch

    This is the same project now playing in r148

    (see how it stops almost immediately-as a result of the various physics settings no longer being changed)

    youtube.com/watch

    And this is the result of moving the physics settings in r148 to below physics enabled. They change now but act completely differently because they aren't connected correctly as a result.

    youtube.com/watch

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • The Physics behavior hasn't been able to change the properties of disabled behaviors ever since Construct 2. I don't believe there is any recent change in this area. It's very common that people mis-attribute their own changes, or other factors, to Construct, but it is possible there is some backwards-incompatible change between r142.3 and r148. If there is we can fix it, but first we'd need a clear identification of what it really is. If you want to dig further in to this the bug report guidelines have been carefully crafted over the years to help you do exactly that, so I'd recommend following that as closely as you can, and to look elsewhere than Physics, because the evidence indicates that is not the cause of the problem. You may well eventually find it is just some other mistake you made though - it happens all the time, and even happens to us with the bugs we file with browser vendors!

  • I can understand the idea of looking elsewhere for the source of the problem, however the most significant problem is that without being able to view my older backups that also display the same problem it's hard to try and even conceptualize the issue. It's not my first time trying to find a bug, and I've no doubt made some dumb mistakes when trying to fix bugs that weren't bugs, etc, before. But it's difficult when I can't reference a functioning older version of the project.

    I had the characters working early with at least 4 folders copied of them working as intended, and loading up all of those projects they are broken in the same way. As in the videos above, there are 3 different results. Pre-r148, Post-r148, and Post-r148 with the events changing the physics moved below the physics enabled action.

    If I could at least view my project in r142.3, I might be able to look through the debug view and discover other properties or variables that are different which could be causing this problem. However because it's saved as a project folder, and the online browser version won't accept that or a newly saved singular file-which I can only produce in the latest version because that's all that the desktop version can access, I can't even properly try and dig further. At least in any meaningfully efficient way.

    Hence why I would so appreciate the ability to reach older versions in the desktop build. As far as I'm aware all it's doing is wrapping the site of r148, with the difference that it can save/load project folders. So if it is at all possible to have some setting somewhere that would allow you to use older versions that would be incredibly helpful.

  • I don't know.. it doesn't seem like you are approaching this like a problem to be solved and rather just want something fixed for you. You seemed to be reacting instead of being active.

    Nothing has changed with the physics behavior since C2, and even if they broken something without knowing there has to be a fix or a work around. What you are saying isn't working is just not that complex (setting density).

    I understand it can be frustrating, but honestly, welcome to the world of programming! I once made an app in Objective-C for iOS and Apple one day changed how certain functions worked which definitely broke my game - since it was already deployed to the App Store. Do you think Apple cared? nope. I had to fix my code.

    This is always a possible risk that some update may break something.

  • Sorry, I admit that the circumstances causing this issue may be resulting in me sounding rushed and desperate for a solution, leaving the incorrect area's of my discussion emphasized. As you say, this happens, and it has happened to me many times in every game engine I've used.

    To try and adjust the focus of my discussion here, what I'm trying to emphasize is that I'm more than comfortable trying to find a solution for this on my end, I'm not asking for a 'solve my problem' button. However to find a solution on my end, being able to open my project in an older version of construct 3 to compare with would be invaluable.

    Currently all I've been able to do is blindly re-adjust how my character's are made without success. If I could open the project in an older release of construct 3 to compare with though, I could debug it fully, check all the values of the characters, re-adjust and evaluate the situation between both versions and come up with a more firm resolution. If I instead just tried to remake my character's from scratch, that would not allow me to identify what caused the issue.

    That's why I so wish to be able to run an older version of construct 3 in the desktop build. Not for it to be magically solved, not to offload responsibility, but so I can better deconstruct the issue and hopefully find what caused the problem.

  • yeah I think it's kind of a big ask, one which I don't think is even on Scirra's radar.

    I would love if they at least had some sort of tool to convert projects and make them compatible by deleting all code that wouldn't work correctly.. then at least you could open newer projects, even if A) they didn't work properly and/or B) they had a bunch of things removed in them.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)