Failed to Open Project. Check it is a valid Construct 3 single-file (.c3p) project.

    Been working on a project's version for some days and i just saved the file. Tried to open it again after some time and it is giving error "Check it is a valid Construct 3 single-file (.c3p) project."

    Is there any way to recover this?

    Edit : The game did hanged in the preview and then i saved, closed and restarted the engine.

    I tried opening project in old version r147.2 it still gives the same error.

    It could be because of changing a parameter name in new function condition because that was one of the last things i did in project that i have a doubt on but i am not sure if it is the reason.

    Have you changed versions of construct since you saved it? If you went back in versions and tried to load it, I have seen it give that error.

    No i have not changed the version as i already was working on latest stable release r148. Although i remember the game hanged in the preview and then i saved, closed and restarted the engine.(added in the first post)

    There is a (very) rare project corruption bug out in the wild which has been mentioned in support a couple of times, but nobody has reported a replication to us yet. If you can find a way of reproducing this project corruption it would be great if you could file an issue for us to look into.

    If you have no backup for that file then I can take a look and see if I can recover it for you. Depending on whats wrong it might be missing some assets.

    Nepeo

    Its an almost complete project, can i email it to you?...

    Also i think it might be due to a parameter name change in the new functions condition because i changed it in the function itself but did not see if it got changed in the events calling that function and so i have a doubt on it also it hanged the game when i previewed it after it, then i saved, closed and reopened it (added in the first post).

    Its an almost complete project, can i email it to you?...

    Sure, send it over to iainkhv@scirra.com and I will take a look.

    Try out some of your ideas as to how you caused the corruption and let me know if any work.

    Just mailed, please check it!

    I am trying to recreate this bug.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads

    Thanks to iain shortcode, he fixed it.

    It was caused due to parameter renaming afterall although i could not recreate the bug itself.

    Thank you iain.

    Sorry for the bump, but this is for the Googlers. This can be due to a problem with a behavior or plugin.

    In my case, I had one machine that could open the project and another one that could not.

    Checking the error console, I saw it was the Lunarray litetween behavior causing an issue. I uninstalled it, then downloaded the same plugin (same version) from the working machine and installed it on the problematic one. Viola. I should try to repro this again and submit a bug, on account of the misleading error message.

    I have to point out that I'm afraid it's not our responsibility if third-party addon developers corrupt your project. You should report any such issues to the addon developer, not us.

    Ashley Same error happen to me and I use project without any third party plugins. Then I keep trying to open it without any change on project or C3 version and did it finally. Don't know what was the reason and how to prevent this issue in future. Buy the way I have couple of different projects with third party plugins and I have never got this error before.

    This thread is a year old, and people keep replying to it with what are likely to be unrelated cases.

    It's best to start a new thread, or file an issue following all the guidelines if you can.

    Also as ever, it's very difficult to help or even make any kind of comment unless you provide either:

    1) the affected project, or

    2) press F12 and include any error messages that were logged

    Since replies to this old thread aren't particularly helpful, closing this thread.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)