SOLVED XBOX Controller X Y B Button Mapping

0 favourites
  • 13 posts
From the Asset Store
Small pixel icons for the 3 most popular controller types.
  • Hi Guys,

    My name is Keith and I am a Sergeant in the British Army. I own a small game studio called AppChogie Games. I have been developing games for PC/MAC and mobile for 20 years.

    I have recently came across C2 and absolutely love it. I have decided to build a game called Undead Fred that I first started on iOS but never finished due to deployment to Afghanistan. I have all the assets so it seemed a good place to go start, I have been using C2 for two days now and already I have the game about 20% completed. (I will post a video etc soon)

    I have decided to set up Undead Fred for touch, keyboard and XBOX 360 controller. All work perfect with regards to keyboard and touch, but when I try to map the XBOX controller X button to a animation change it dosent work. I have mapped analogue left / right and A button using the "simulate platform" feature and they work perfect.

    Any ideas? I have been looking in the manual, forum and internet. The code seems logical but it does not work. At best I have made the X button start the 1st frame of the attack animation.

    Lastly I have tried the XBOX controller test site that another user created and it all works perfect.

    Thanks for any help


  • I still cant find away of getting the other buttons (X, Y, B) mapped correctly apart from the "Simulated" L/R and A.

    I have played other people's games on the Arcade that have it working?

    Please point me in the right direction.

    Thank you


  • Update:

    I have updated to the new beta build this morning.

    So after alot of trial and error trying different ways to trick the buttons, I made a diagnostic live event sheet for the XBOX 360 wired controller. This enabled me to see if in fact the gamepad buttons were accepting the button presses even tho nothing is happening on screen.

    The short answer is YES they are working, so that in mind I tried the normal code again.

    Gamepad: Gamepad 0 Button X is down: Fred : Set Animation to "FredStrike" (Play from begining)

    With this method the gamepad reacts on the X button however only plays the 1st frame of animation again?

    Has anyone got a working file that could help me with this. I have emailed the C2 devs and hope this is an error as it is driving me mad!



  • Just a shot in the dark here, but maybe if instead of using 'X button is down', could you use 'On X button pressed'?

  • dpyellow thanks for the reply. I have tried that mate with no luck.



  • Try this. If it doesn't work for you then it's an issue with your controller. If it does then clone it to work with your sprites.

  • Burvey,

    Thanks for taking the time to look at this for me, however your example is the way I originally coded it.

    Your example does work with my gamepad, but for some reason not in my game?



  • SOLVED!!

    It is due to the restriction of triggers on the free edition. With keyboard, touch and joypad I am using too many. If I disable some other it works.

    The fix is for me to purchase a licence! lol

    Thanks for all the help.

  • Most likely some of your settings in construct 2 are incorrect. Can you post a capx?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Burvey please message me your email and ill send you the file via dropbox. I don't really want everyone having it.

  • Sounds like you figured out the issue. :)

  • Does that sound like something that the free edition could limit? I read that it only allows 100 events.

  • I really don't know. It's possible.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)