Pseudo 3D-Egoshooter stucks...Help needed!

  • Hey friends,

    I made up a prototype game in construct. It ran super fluent, never lagged.

    Than I reopened it yesterday and now it stucks in every browser and on every computer.

    Already checked the graphic card drivers....:-(

    and cleared the cache....doesn?t help!

    What else can I do?

    dropbox.com/s/qzkou4oskgawtud/Beavs_VS_Trees.capx

  • Exported the game and played about 20 seconds absolutely fluent, then my browser crashes and this message appears

  • Well, I tried several times, and it did crash a couple of times, but it would also play fine for long periods of time as well. I tried it both in Firefox and Chrome. It seemed to run better in Chrome...

    I ran it in debugger mode several times too, and most of the work is being done TransformWorldXYZ. I thought maybe it was getting stuck in an infinite loop or something like that. But I don't see any problems there.

    On my system it would occasionally stop for a few seconds, but then keep going. I thought that might be cause by garbage collection, but there is very little creating and destroying of objects.

    So, I didn't see any obvious problems...

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Hey, thanks for sharing your thoughts.

    I have absolutely no clue, where this comes from.

    The greatest miracle is, that it just happened when save/reload the project. I'm really sure that I didn't change anything.

    Perhaps it's a bug?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)