How to fix blurry pixel sprites

  • Okay, I found the answer as this is the first thing that pops up in Google search. Also note the date of my post as I'm using the most current version of C2.

    1) Click to the project propriety window--

    2) Mess with all the "Project" and "Configuration" settings.

    After turning things on and off I got my game to load with no blur.

  • I have the same problem, i am looking for objects to not blur at all at high speeds, just like Super Nintendo or Sonic games, i still can't find a solution.

  • If you go to project properties find the option sampling and set it to point that fixed it for me.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • If you go to project properties find the option sampling and set it to point that fixed it for me.

    Thank you sooo much! This worked for me

  • I know it's an old post, but I just thought I'll post this in case anyone else has problems with blurry sprites.

    I've just spent the whole day trying to figure out why all my sprites were blurry with 'linear' sampling on my PC but not on my mobile (changing the sampling in project properties to 'point' did help, but I didn't like it as the graphics weren't as smooth).

    As it turns out, it wasn't a problem with Construct 2 but with my graphics card settings - you need to increase the graphics quality in your graphic card settings. Now, everything should look good!

    I hope this helps someone.

  • ......

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)