Problem with touch on some devices

0 favourites
  • 8 posts
From the Asset Store
All popular touch mechanics - scrolling, zooming, swiping
  • Hello, I work with construct 2 a few months ago, I am developing a game called Billy The Ball, the home screen is a button that opens when touched another layout, but am having trouble with this sprite, some people are reporting in this button does not work and performing tests on devices that have no problems at home, I asked some people to remove them, and install again, but no solution, I wonder if anyone has any idea what might be causing the error.

    For those who want to know the game and can test a possible error just go to the store and look for Billy The Ball

    remembering that it is a touch event on a sprite object that opens another layout

  • I tried it. On my device, I can get to the title screen, where I see a big silver button (which I assume I have to touch to go to the next layout). It doesn't work.

    I tested it on a Galaxy XSII.

  • exactly, most of the devices that had an error, were samsung.

    I am seeking a solution to this for some time but nothing resolves, I tried to change the event so that change the layout when you click the button and other things but none worked, and worst of all this is that before I update, it was working, but I did not change this part of the project

  • Check the collision polygon for the button. Sometimes that can bite, especially if your button has some transparency. The touch object detects within the collision polygon...

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I checked, the big problem is that the error occurs apparently in samsung devices, no problems on other devices. I have a LG P350 and Motorola Moto G(XT1033), I tested both and there was no problem.

  • Hi Zonic3000,

    I tried the game on my HTC Desire, and couldn't open the app using the silver button.

    Let me know if you need me to test any updates :)

  • Hi.

    Maybe you can try to use "drag and drop" instead of "touch".

    I use that for all my buttons and it works very well (i use transparent buttons on top of my image of the button, and my actions are done on start drag).

    Don't know if it will work (I don't have a Samsung), but it's an alternative that works to the "touch", if the problem comes from it.

  • Hi guys, I solved the problem, there was an event within another eventsheet that was deleted and I had not noticed. I ask them to test again, if there are issues to report me email, thank you all. I'm uploading to the store again. I hope you enjoy the game

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)