Performance issues

  • My game is unplayable on Mac with node-webkit, ~60% of the graphics are missing (I've tested on a couple of macs, one of which is a brand new upto-date Mac mini). It only seems to run the basic Scirra demos fine.

    I'm hoping the new node-webkits will fix this issue...

  • The main cause of poor performance and crashes is graphics card drivers. Make sure the whole system is up to date and check directly from the graphics card vendor for updates.

    I updated everything and its running better. The OSX version still crashes before even loading. The icon just bounces in the dock, and then if you click on it it disappears.. is this a known bug? Is there a fix?

    Thanks for all the help!

  • Try r127 - it includes an updated version of node webkit.

  • Are you using an intel integrated graphics card on the other computers?

    I've tested my game on a few computers and it always gets a little wonky if it has one of these graphic cards, even if they're updated. I've had no problems when using AMD or Nvidia graphic cards though.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Are you using an intel integrated graphics card on the other computers?

    I've tested my game on a few computers and it always gets a little wonky if it has one of these graphic cards, even if they're updated. I've had no problems when using AMD or Nvidia graphic cards though.

    Yes, It is my macbook air. So it has an integrated card. But the windows version works fine, even through VMare. Its only when I try to launch the OSX version that I have the issues,

  • this if funny im having the same performance issues by me as well

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)