New NW.js v0.18.0 doesn't work

  • I went out of my usual way and directly reported it to the NWjs team. (HERE)

    I hope I've done it correctly and I'd appreciate a star/upvote to get this bug fixed as soon as possible.

    I've also noticed there is a chrome menu appearing when right clicking on a button!

    Scroll down and do the steps as mentioned in my post. (HERE)

  • TheRealDannyyy

    Have you tried the more recent 0.18.2 to see if --single-process works?

    https://dl.nwjs.io/live-build/10-24-201 ... 6/v0.18.2/

    That arg is really handy for Steam, as it can bypass some issues as you reported, but also gets the overlay to be more reliable too.

    I'm testing the OSX build and using the browser -> close to exit doesn't fully exit, game still runs in background and won't allow Steam itself to exit. Problems, problems!

  • Have you tried the more recent 0.18.2 to see if --single-process works?

    My bugreport is still open and there was nothing about it being fixed in the changelog.

    I don't like to install NWjs by myself anyway, I'd rather download Ashley's version here so I won't do any mistakes.

  • nw.js 0.18.2 still close with arg --single-process (win7-64 / nw.js0.18.2-x64)

  • MadSpy

    Thanks. I dug through old topics about NWjs not closing properly and your name always came up.

    Do you know if your Node Extended plugin works with MAC export? I'm having a problem with my MAC build on Steam, on close (Browser -> Close, or Window X, Command +Q etc) it exits the game but not fully. Steam thinks the game is still running so it cannot relaunch and Steam cannot quit due to an open process.

  • , which OSX version do you use?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • , which OSX version do you use?

    El Capitan.

    I'll test it with Sierra tomorrow.

  • MadSpy

    Tested the latest NWjs 0.18.3 build, with OSX Sierra.

    The --single-process still crashes.

    However, the exit problem with Steam no longer occurs, it correctly exits.

  • Do you try --single-process as command line instead of arg in package.json?

  • MadSpy

    Both. Node crash on launching with it.

    Edit: And for some insane reason it's now not exiting properly again, game still runs using various methods to close it, including CMD + Q, Browser -> Close, Windows X etc.. I suspect it's Steam's overlay trying to inject itself into one of the nw process and this causes issues. Hopefully they fix --single-process arg soon, I'll test again then.

    Edit2: Can confirm it's the Steam overlay injection. I disable overlay and the game exits just fine!

  • I've tested the latest NW.js 0.19 beta1 and it works:

    http://nwjs.io/downloads/

    I've also niticed a CPU usage drop, can someone confirm it?

  • nw.js 0.19.0 beta is not stable.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)