Multiplayer connectivity problems

  • Yes, I think it's TURN server configuration issue. I changed the listening port to 80 and it started to log connection attempts, which unfortunately fail.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Ashley , xoros did you manage to make it work ? i having the same issue,

    My problem is that i want to open the "chat demo" in a separate machine to work as Host, this "host" is a dedicated server windows machine, with apache, where my "chat demo" is hosted , the problem is when i tried to connected from another machine, it connects but i can't see others peers and eventually i get kicked

    i added the Turn server with the multiplayer object, before the multiplayer signal connect action ,

    "turn:mydomain.com:port" , in my case i don't have setup any credentials

    i setup the server following this tutorial , i installed on a window machine with cygwin, it runs ok,

    in this windows server machine i ran the Chat demo (modified to add the TURN ) , in a web browser, so it will served as host (that is my main goal)

    in the turnserver.conf:

    listening_port = 3478

    listening_ip = 192.168.0.1

    then i have a NAT from the router to UDP/TCP Port 3478 to 192.168.0.1 ip

    in the Chat demo i added it as "turn:mydomain:3478"

    nothing work,

    then i added manually to c2mp.js where the ICE server are hardcode, as the first one,

    var DEFAULT_ICE_SERVER_LIST = [ { "urls": "turn:mydomain.com:3478" }, { "urls": "stun:stun.l.google.com:19302" }, { "urls": "stun:stun1.l.google.com:19302" }, { "urls": "stun:stun2.l.google.com:19302" }, { "urls": "stun:stun3.l.google.com:19302" }, { "urls": "stun:stun4.l.google.com:19302" }, { "urls": "stun:23.21.150.121" } // mozilla-operated server ];

    it worked after serveral F5 in the browser, but just one time, i have managed to get Logs

    2852: handle_udp_packet: New UDP endpoint: local addr 192.168.0.1:3478, remote addr REMOTE_IP:59812

    2852: session 128000000000000001: user <>: incoming packet BINDING processed, success

    2852: handle_udp_packet: New UDP endpoint: local addr 192.168.0.1:3478, remote addr REMOTE_IP:59813

    2852: session 128000000000000002: user <>: incoming packet BINDING processed, success

    but still, i couldn't see the Host or the others peers

  • Nope. I haven't manage to fix it. Anyways WebRTC is not supported on iOS. I'm still using socket.io solution by

  • xoros

    I am moving to firebase + parse for multiplayer (network) recently.

  • rexrainbow, thanks gonna check it out

  • I'm having problems with certain people to connect to me as well, they can connect fine as a host, but they can't connect to me (gets kicked as soon as they join), will a TURN server help me with this? Or can it be a port issue?

  • Anyone solved that ?

  • This multiplayer feature was a waste of time. I works for no one. And if it works, it don't.

    lol

  • xanxion

    Currently I'm using photon cloud plugin - very good stuff and easy to use. Recommended:

    https://www.scirra.com/forum/plugin-photon-cloud_t125222

  • xoros: I'm using Multiplayer Plugin now and deploying my own Turn server.

    is the config like below is correct?

    "turn:my_username@<turn_server_ip_address>,credential:my_password"

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)