Feedback request: new PhoneGap features

  • Ashley Arrgh.. I just tried again with Phonegap Build - but I hit the 15MB upload limit. Even the 40MB limit on the paid service is really quite low for media rich apps, especially with new 1920×1080 resolution retina images on the iPhone 6+

    Looks like I need to figure out how to properly add plugins to Phonegap CLI projects in XCode.

  • Thanks for the IAP update, Ashley! I'll be testing it soon, but in order to do that, I'll also need a "consume product" action for consumables. My use case for this is purchasing in-game currency, so they player should be able to buy as many of one item as they want. In order to do that (at least on Android, not sure about iOS), the product has to be consumed before purchasing again.

    Very excited about getting this feature complete for both platforms so I can do a full release soon

  • Is the new Admob plugin working with Phonegap Build Service? I tested it on iOS and Android and there is nothing showing up. Also shouldn't there be a somehow called "cranberry admob" plugin reference in the exported config file?

  • MACPK - no, AdMob can't be built with PhoneGap Build right now, it's only supported on Crosswalk at the moment.

  • Ashley - thanks for the info. It might be helpful to put this to the plugin description, so weather a plugin is supported by Crosswalk, Phonegap CLI or Phonegap Build Service.

    Am I right that there is currently no option to monetize Phonegap Build Service apps on Android? So we still need Crosswalk for that?

  • Hi

    I get this error when build with XDK:

    My game only uses the AdMob official plugin

    Error: Plugin failed to install: com.mcm.plugins.androidinappbilling (com.mcm.plugins.androidinappbilling)

    Any ideas?

    Thanks

  • any chance you can post the full build log? That will give us more information

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Hi imaffett I created a bug report at Intel HTML5 forums

    https://forums.html5dev-software.intel.com/viewtopic.php?f=37&t=9769

    They said it was a network problem so I tried with a different network and it worked (so weird).

    Thanks!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)