Construct 2 in Virtual Machines Comparison

0 favourites
  • 4 posts
From the Asset Store
Casino? money? who knows? but the target is the same!
  • Until the day Construct is available for Mac (sounds like Construct 3 might be) Mac users can run it in Virtual Machines like VirtualBox, VMware Fusion, or Parallels. My game has grown to be over 80MB using about 300MB of RAM with it's 400+ events. So it's taking a while to open and export now. So figured I'd compare the free VirtualBox I'm using to the paid solutions Fusion & Parallels. The reason I'm so curious about these results is because Construct is about the only use I still have for booting up Windows so figured I'd best pick whatever is best for C2.

    I'm running Windows XP SP3 and the latest version of all 3 of these programs at the time of writing this and these were my results.

    Time to open my project:

    VirtualBox = 1min 8secs

    Fusion = 0mins 50secs

    Parallels = 0mins 27secs

    Time to export my project. (Minify Script enabled / PNG compression off)

    VirtualBox = 6mins 06secs

    Fusion = 4mins 34secs

    Parallels = 5mins 35secs

    The results are interesting to say the least. One thing to remember is Fusion and Parallels are not one time purchases, compatibility tends to break with later version of OS X that require paid upgrades to their latest versions.

  • Great post... I used Fusion a long time because I had serious problems with the marketing strategy of Parallels. Fusion worked ok, until I experienced several problems with the Construct 2 UI.

    Somehow my layouts did not update but stayed black, action items suddenly appear/disappear when hovering with the mouse over them...

    Also testing the games in the Edge (or other browser) show a lot of lag. Last weekend I installed Parallels v11 (trial) and guess what... everything worked like a charm! Fast and no problems!

    I do have to give Parallels the credits at this time

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I have also encountered the problem of layouts turning black inexplicably under Vmware Fusion Pro (Windows 10). Has anyone else encountered this problem and/or figured out a solution for Vmware Fusion Pro users? Should I be asking about this in a different forum?

  • No harm posting about it here, but your best chance to find a workaround or have them fix the issue is to probably email them at or tweet them at

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)