collision polygon issue

  • So I'm making a top down shooter and I've encountered an issue, when I set the collision polygon it works great until I shoot, then it reverts back to the oversized square that leaves me not being able to walk through doorways properly. When I bump into walls, my player is a good inch and a half away when I get stopped. Any suggestions on how to fix this? Could it be the browser I'm using to run the game? If so how can I switch to chrome? Thanks in advanced.

  • This is because you probably set the collision polygon for a single frame. Open your sprite, select the "Set collision polygon tool" and then right click on sprite-->Apply to whole animation

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • This is because you probably set the collision polygon for a single frame. Open your sprite, select the "Set collision polygon tool" and then right click on sprite-->Apply to whole animation

    ERRR I cant believe I didn't catch that lol. Thanks a bunch man. Also an issue I'm having is when I'm moving forward and to the left I cant shoot until I stop moving forward or to the left. I didn't include it because it wasn't a collision issue.

  • It would help if you could attach a capx file to identify the issue, but the forum rules require a rep of at least 250 to do that.

    Can you try and explain how you have set up the movement and shooting?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)