Cannot Preview on LAN

  • rekjl,

    Haven't used instant wordpress for ages. Let me download and install quick.

    Oh, cool, its better than I remember :)

    Your wp installion is in iwpserver/htdocs/wordpress/

    You want to create a folder

    iwpserver/htdocs/wordpress/games/

    Now create a folder for your game and export game to this folder.

    launch instant wordpress and click wordpress front page - it will launch internet explorer at a url like this

    127.0.0.1/wordpress

    Now either via wordpress you can create a website and link to games via menu etc

    Or just type in your browser of your choice:

    127.0.0.1/wordpress/games/zombie

    Maybe I will make my first tutorial today if I get a chance, but this should sort you out.

  • Thank you times a million!! I really appreciate it! Hehe it's time to test and try it out!

  • DUTOIT, I installed it and followed your instructions, was able to get the game to run on my browser, but when I type the exact same url into my phone, it shows the same message as with C2 preview, that the website is currently not available. What do you think might be the problem?

  • rekjl

    No problem. Here is the Tutorial

    Edit: You are right - hold on, let me investigate

    Damn, I'm an idiot. So sorry, you need the network ip not localhost.

    Instant Wordpress doesn't use network. It ain't going to work unless I hack the code.

    Xampp works, I use it. Will have to write up tutorial on that instead.

  • DUTOIT, Thank you so much. I will patiently wait for your tutorial. <img src="smileys/smiley4.gif" border="0" align="middle" />

  • I've been meaning to update my install of xampp to latest version of php, so guess this is as good a time as any.

    Will be up in a couple hours time ;)

    Got to run some errands.

  • rekjl

    DUTOIT, Thank you so much. I will patiently wait for your tutorial. <img src="smileys/smiley4.gif" border="0" align="middle">

    Here you go: The Tutorial

    I hope it works for you. If not then are you connected to your wifi via your router? and firewalls etc. But this should do it for you ;)

  • DUTOIT, I don't know what else to say but thank you! THANK YOU! It finally works for me! So excited. Although I found out that one of the problems was my HTC one phone. I don't know why, but it couldn't connect at all. I tried my old phone, a sony ericsson and it works. So will have to test with my old phone and find a solution for the new one.

    Oh, and did I mention thank you <img src="smileys/smiley36.gif" border="0" align="middle" />

  • You're very welcome :)

    Glad it worked out for you. Nice thing about this set up is you have access to mysql databases if you need them, and anything else you might ever need for a game.

    Is the phone using your wifi network? Connected to the network and assigned an ip. My one laptop ip ended up being 10.0.0.9 when everything else worked on 10.0.0.3

    You can configure the ip range via your router settings ;)

  • DUTOIT, yup, my phone is using my wifi network. I went inside my router to have a look at the settings and my android phone is given a different ip address, but it is shown and supported in my router. Haha that is why it is weird. My phone can connect to the Internet and everything, just can't connect to the games.

    Haha will just have to slowly take a look.....although....it might be a good thing. Hehe better to test my games on my old SINGLE CORE phone. If it runs well there, it should run well on any phone <img src="smileys/smiley36.gif" border="0" align="middle" />

  • I was having same problem and I actually posted my own "How Do I" before I found this. My solution, after a lot of searching, was to not type the "http://" before the ip address and it worked! Hope this helps!

  • , haha it's been so long that I almost forgot how to set it up. But will definitely give it a try soon. Would be fantastic if it indeed solves the problem.

  • Dear All,

    hopefully I found the solution for this problem.

    Please check if You are on a Public Network (You can see on the opening page of the Windows Firewall)

    If Yes, then open the "Construct 2 Preview on LAN" entry, then on the Special settings click the "Public network" checkbox.

    This solved my problem.

    All the best

    Zs

  • vargazso you are a genius!!!!!!!!!!!!!!!!!!

    i think this is the problem for everyone, you deserve a trophy!

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Ashley this solution needs to be added to the troubleshooter, i was lucky to have found it after digging for ages

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)