Wrap issue?(not similar to the ones I've seen)

0 favourites
  • 10 posts
  • Hey everyone. I'm having an issue with my character getting "stuck" during wrapping. Sometimes he doesn't appear on the other side. Also when jumping from the top of the screen, like in the demo level below, he doesn't reappear at the bottom of the screen. Not sure if it's a bug or something I'm doing wrong. If you jump around awhile on the top platform you'll see what I mean.

    Demo Stage

    .cpx -> Here

  • What is your browser ? OS ?

    I've tried the link "Demo Stage" on FF 7.0.1 in win XP, the wrapping appeared to work in every levels.

  • I've attempted a fix for the next build. When it comes out can you let me know if it fixes it? Thanks.

  • Is this fixed in r67 by any chance?

  • I've since transitioned into just writing the wrap ability into the event sheet as "if x >= 640, then x = 1". I tried switching back to just assigning the character the wrap behavior after r67, but it still glitches at the top of the screen. He just sort of jitters for a second then comes back down on the platform without ever coming up at the bottom of the screen. Thanks for the reply.

    <img src="http://i629.photobucket.com/albums/uu20/eochranek/Trepidation_Glitch_00.png" border="0" />

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Hello, I seem to be having a very similar problem with the wrap behavior. It'll go to wrap around the X axis but then it'll jitter most of the time. Then wrap oddly. I've used Firefox and Chrome. (Chrome seems to work much better with Construct 2 because when I test in Firefox the whole game screen will flash that's sort of off topic but just thought I'd mention that.) And you also asked what OS we're using. I'm on Windows 7 64 bit. And I'm running the newest build of Construct 2. Is this a bug still or am I doing something wrong?

  • Sorry to bump but don't know if anyone saw this. Still wondering if it's a bug or am I missing something to make it work properly? Thanks.

  • Same deal. I experience this mostly with the car behavior, in which if i drive in reverse to the outside the screen it jitters/go's wacky.

    Also, if you don't mind me suggesting. A margin property for the wrap would be great.

  • Same here. Some items in my game are going off the edge and not coming back on the other side. I noticed it when I set the layout to be full screen (scale). If you play the level every so often you can see an enemy sprite just going up (or down) a channel off screen. Weirdly they may suddenly 'jump' on screen for no reason. Hope seeing this might help?

    Using latest build btw (RLS 87)

    http://dl.dropbox.com/u/74633005/ast.capx

  • vandinz can you reproduce the problem in a new project?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)