The view tab is always a black bar

0 favourites
  • 10 posts
From the Asset Store
This Girls Game allows young fashionistas to develop their taste and skills as a fashion designer.
  • Link to .capx file (required!):

    It happends in every project.

    In the caps I show the project "Ghost Shooter (Rain Demo)" that comes with Construct2

    Steps to reproduce:

    1. Create a new project or load one. Any of the examples included in Construct2 will do.



    Observed result:

    The View tabs beacomes a black bar or a copy of whats under.

    And in some projects the Layout view is all black and crashes if clicked.

    Expected result:

    Browsers affected:

    No browser involved

    Operating system & service pack:

    Win 7 x64

    Radeon HD 7970

    Construct 2 version:

    r152 - Homepage Download and Steam Version

    Currently have Catalyst driver 13.9. But tried upgrading, downgrading and beta drivers with exact same results.

    Later I tried different releases downloaded from the Construct2 homepage. I found that from r154 to r148 all present the exact same behavior (yes, I tried the all one by one). BUT r147 and lower work correctly without any modification to the graphics card drivers

    some screen caps the examples included in r152

    the cap of Ghost Shooter (Rain Demo) from release 152

    and the working cap of Ghost Shooter (Rain Demo) from release 147

  • These are nearly always GPU related driver issues. Although it could be left over settings in registry, and folder.

    Have you tried changing the C2 theme?

  • Ok tried the other themes. Some present the same symptoms, some break the GUI even worse. The only theme that lets me see the view bar is Scenic.

    Still when loading Ghost Shooter (Rain Demo), the games tab doesn't render the content (is a black square or the image of the previouly selected tab)

    No issues changing themes or opening projects in r147.

  • This must be a driver issue with your system. Nobody else is reporting it. If the latest drivers still have a problem, report the issue to AMD.

  • I also have the same problem. I thought it was the update, but when I reverted back to 1.5.2 the problem didn't disappear.

  • Yes, the problem appeared after an update. But I don't know witch version I updated from. So I had to go all the way back to 1.4.7. That's the latest version that doesn't have this problem.

  • But it is weird. On other PC's I tried the latest version of construct 2 worked perfectly well, so did mine, albeit with an older version. It was the 1.5.4 version that gave me this problem. Also, I checked every driver if it was up to date, and it is. I hoped that the 1.5.5 version would hopefully fix this, but it didn't. I haven't tried reverting back to older versions, such as 1.4.7. I hope it works, though I would really like to work on 1.5.5.

    EDIT: Reverting back to 1.4.7 seems to work. However, this isn't really a solution I'm happy with. There must be a reason why this black tab is showing on newer updates and there must be a way to solve it.

  • Nothing? I just got the latest update and the tab is still black.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Did you try updating your graphics card drivers?

  • Yes I did, and everything was up to date. I really don't know what else to do.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)