Tilemaps texture demo no save

  • Problem Description

    The demo of the Tilemap object won't save a new imported texture

    Attach a Capx

    Use the tilemaps template

    Description of Capx

    Open the template.

    Steps to Reproduce Bug

    • Open template
    • Switch default texture with another
    • Save capx somewhere

    Here is a test texture: http://opengameart.org/sites/default/fi ... 2Tiles.png

    Observed Result

    Old texture is saved rather than new.

    Expected Result

    New texture saved rather than old.

    Operating System and Service Pack

    ____ Your operating system and service pack ____

    Construct 2 Version ID

    203

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I just noticed this today while trying to update a tilemap image. I have also recently observed this exact behavior with sprites as well. :/

    Sometime restarting the application alleviates it.

  • Yeah I unzipped a capx and sure enough the old texture was the only one there.

  • If I use 'Tiled' to import and export, I can update tilemaps that way.

  • Well I just opened my project after updates made to tilemap via the 'Tiled' export, import route, and lone behold... The old tilemap image is back :/ Can't update tilemap images without creating a new one.

  • This one has probably been around a while.

    Might say just community testing isn't efficient enough.

  • I think you are correct newt

    I have been doing some further testing on this issue. I went backwards with C2 installs (back to 196.2) and it didn't resolve the issue with my current tilemap. If I create a new tilemap it seems to alleviate the issue. Which leads me to believe that somewhere along the line a C2 version broke / corrupted tilemaps files - and then was fixed, but left issues on past tilemap files(?) Also It seems that not only are tilemaps effected, but sprites as well. For I have been having to manually replace any image I want to update in C2.

    Tilemaps :

    Updating through C2 does not save. Doesn't even update texture while open.

    Updating through Tiled appears to save, until next opening of file.

    Manual updating via the project folder files : solves issues. (so far from what I can tell)

    If I manually update Tilemap texture via project files, it works and saves.. And once that's done I am able to update inside of C2 (this is also the same method I have been using for sprites as well)

    I first noticed this issue on r200 with sprites.

  • Yeah I noticed it a while back, contributed it as user error.

  • Thanks for the report, should be fixed for the next build. I can't reproduce any issue with Sprites though, please file a new report if you still have an issue there.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)