Tilemap Unresponsive Script

0 favourites
  • 2 posts
  • Problem Description

    Loading layouts with a 2048x2048 Tilemap in them causes Unresponsive script error (tilemap_plugin.js or glwrap.js) in Firefox and noticeable delay in other browsers (Chrome/Edge/IE). Game will eventually run on Firefox as well if the script is continued despite warnings. Changing the source image did not affect the issue.

    This issue also persists after the project has been exported and my friend reported the same error when playing my game on Firefox.

    I thought there might be something wrong in the Tilemap-plugin so I tried reinstalling C2 and installed r245 Beta but it didn't solve the issue.



    Attach a Capx

    https://drive.google.com/drive/folders/ ... WpBalpjWWs

    Description of Capx

    2 Layouts, other one has a Tilemap in it and other doesn't.

    Steps to Reproduce Bug

    Open the Capx file. Run the layout with a Tilemap in Firefox.

    Observed Result

    Tilemap script is unresponsive (error in Firefox, delay in other browsers)

    Expected Result

    No errors, no noticeable delay.

    Affected Browsers

    • Chrome: NO (or partially)
    • FireFox: YES
    • Edge: partially
    • Internet Explorer: NO (or partially)

    Operating System and Service Pack

    Windows 10

    Construct 2 Version ID

    r244 & r245 (beta)

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Your tilemap has over 16,000 tiles in the tileset image. Is this something you really need? It seems like a case deliberately made to be slow. C2 has to cut up the tiles from the tileset image when the layout starts, and it seems Firefox is slightly slower at doing this, and takes long enough to show a warning.

    Unless you have a real-world tilemap that does this, and you can't make it smaller, closing as won't fix.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)