Chrome for android audio lag

  • How are you measuring latency?

    I don't think there's anything we can do anyway, since the delay must be in Chrome or possibly the Android OS. There is no delay on C2's side, it says to play audio right away, and it does play right away on all other platforms.

    Ashley , i'm recording the device(see the video in the first post), and each frame of delay between the collision/sprite turns visible and the sound, represents 33ms if the video is 30 FPS(1/30*1000), but i shot the videos at 60FPS for more accuracy.

    It seems that is a Chome problem(crosswalk does the same), but it's weird that very few people noticed this.

    Thanks anyway.

  • I have the same problem, the audio has latency on my Galaxy S4... but on my IPAD 4, the audio is perfect... Someone know how to fix it?

  • I'm getting the same latency issue with sounds on Android. On iOS there is no issue. Just tested on a Hudl 2 -Android 4.4.2

    Anyone have a fix or is it baked into Chrome?

  • I think it's baked in to the Android OS. Android 5 apparently has better audio support so perhaps it's better there.

  • Bumping this thread to say I am encountering this issue with both crosswalk and chrome for android. I don't think it's an issue with C2, but neither do I believe it's an android issue, as firefox mobile has a very minimal delay when triggering sounds, whereas chromium based solutions lag nearly a half second.

  • TiAm

    OK, but maybe we have to fill a bug report in Chromium, I don't know if anyone reported this to Chromium.

    The only way to measure lag is to shot a video(see my video), import to a video editor, and each frame of delay between the action in C2 and the sound represents 33ms for 30FPS videos(1/30*1000).

    I only have 2 Android devices rigth now, but we have to know if this affect all Android devices and OS version, because Ashley said his Nexus 5 was fine.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Well, I found the relevant bug report:

    https://code.google.com/p/chromium/issu ... ?id=424174

    With the jank issue, we managed to push bug 42200 into the top 25 bugs on the chromium tracker, by star count. That's out of 72,000 open issues. It also got the problem mostly fixed (for now... <img src="{SMILIES_PATH}/icon_e_confused.gif" alt=":?" title="Confused"> ).

    Maybe it's time for another round of 'let's nag Google'. <img src="{SMILIES_PATH}/icon_mrgreen.gif" alt=":mrgreen:" title="Mr. Green">

  • Well, I found the relevant bug report:

    https://code.google.com/p/chromium/issu ... ?id=424174

    With the jank issue, we managed to push bug 42200 into the top 25 bugs on the chromium tracker, by star count. That's out of 72,000 open issues. It also got the problem mostly fixed (for now... <img src="{SMILIES_PATH}/icon_e_confused.gif" alt=":?" title="Confused"> ).

    Maybe it's time for another round of 'let's nag Google'. <img src="{SMILIES_PATH}/icon_mrgreen.gif" alt=":mrgreen:" title="Mr. Green">

    It seems a good tactic <img src="{SMILIES_PATH}/icon_e_wink.gif" alt=";)" title="Wink">

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)