Admob ads not working in Cordova since last C2 update

  • ok bro thank you very much for your responses much appreciated .

  • > I'm using ultimate ads and I have exported with phonegap, and the ads work but when I put the apk on google play the ads are no longer displayed do you know why?

    Did you change the test mode to false before publishing?

    yes I have disabled the test mode the ads go but only when public on google play the ads disappear how can I solve this?

  • I am pretty sure it must be a misconfiguration in the admob panel. Not sure how you setup it, but you may checkout permissions in config.xml before uploading to phonegap, or making a sample app with just admob plugin and try again, so you discard any plugin conflict in production.

  • but I do not think because before the ads were going the only thing is that I changed the plugin because before I used cordova admob and it worked. But then this plugin became deprecated and I had to use ultimate ads

  • no it's not about plugins I've tried the old cocoon ads plugin now and it works outside of google play but on google play no I do not know what to do I've even contacted google but I have not received any answer

  • You may contact Toby R which made the plugin and offer great support, and may have experienced this before

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I have been pulling my hair out all day trying to figure how why Ads and Google play would not work. You are a life saving, thank you so much for this.

  • I have been pulling my hair out all day trying to figure how why Ads and Google play would not work. You are a life saving, thank you so much for this.

    You're welcome! :)

  • Hi, i used cocoon ads android admob plugin 2.0.0 and result black screen, but when i used cocoon ads android admob plugin v 1.0.12 (or 1.0.11) the banner ads did't showing.. any explain about this?

  • Have you tried loading and showing an interstitial? Just to make sure it is not an admob misconfiguration

  • Tried an interstitial? Yes, interstitial is working...but why banner doesn't show?

    above is first setting : not work

    next is second setting

    but both of them is not working...setting layout banner : top center, just two month ago is working as well..i never change my setting..until i know it doesn't working anymore..

  • But you have all the banner actions in the same condition, which means you are trying to load and show at the same time, that's not a good practice, you must let the banner load first, and when banner is loaded (on banner loaded) then show it and by the way load the next one, so it won't work just once...otherwise you may show it without having got it in your device

  • Thanks. Hmm,, Ok but why it work on another version of contruct2. I used C2 r239, and my setting worked. ?

    and i use r239 now that what i think more stable.

    I never change my setting above, and i don't know why...it works again..

  • Hello, I got an error while trying to run my app after build using cordova, so when I start the app it's only showing black screen. It's happened after I added some admob plugins alternately into the project, but when I tried to remove the plugin and build it again the app works fine (but with no ads). I've asking my friend try to build it on his computer by using the same way and he got the app works (not showing black screen + showing ads). I think there's something wrong with CLI that I used, anyone know what happened?

    (I used "cocoon-plugin-ads-android-admob" & "cordova-plugin-admob-free" on the cli and both result the same errors by showing only black screen)

  • Which admob plugin and version are you using?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)