0 Favourites

Text Box Mysteriously Disappearing in Arcade

  • I just uploaded a game for the first time to the Arcade (http://www.scirra.com/arcade/addicting-puzzle-games/5932/demathmatica), and for some reason the text box the player inputs answers into disappears. The game works fine when I run it in preview mode, so I'm not sure why it doesn't work when I uploaded it.

    You can see the text box for an instant before it vanishes in the arcade. I've attempted putting a white square sprite behind it, as well as running a few different set visible events. The last thing I tried was to put it on it's own layer above everything else.

    Edit: Disregard this entire post. It is now mysteriously working, with no additional effort on my part.

  • Glad you fixed it.

    This sometimes this happens when the text box is too small for the text.

    It might show fine in Construct 2, with for example Arial, but once the web font loads it can be larger than the box and then the text disappears.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Oooh, that makes perfect sense, now why didn't I think about that? That information will be very helpful for future considerations, thank you aquinn.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)
Similar Topics Posts Views Last Post
Unread hot topic
0 Favourites
[Plugin] tag text
188 25,440
RBuster's avatar
RBuster
Unread hot topic
125 14,835
Per Atwood's avatar
Per Atwood
Unread hot topic
0 Favourites
Can't Upload to Arcade
104 739,318
foxrain4's avatar
foxrain4