0 Favourites

Arcade Whitelist

  • Hello,

    Im having trouble uploading my game to the arcade it says that my Arcade export zip file contains stuff that is not on the whitelist.

    I went on and checked forums posts about it but couldnt find the real issue, the only plugin i used is WebStorage.

    Is it possible that the use of an outside font cause this?

    The controls are keyboard/mouse but it is also possible to use a gamepad, can it be what causes the problem?

    Is there any way to know what isnt on the whitelist inside my zip file?

    I used to have the pause plugin i my game, i removed all uses of it and removed the Pause object from my game but is it possible that some part of the plugin remains?

    Im not a native English speaker so i apologize if i made any spelling mistakes, thanks for reading me and thanks if you help me :D

    (Also thanks to the people answering questions in general, so many forums posts have helped me in the past two months!)

  • The game is working on kongregate for those who want to see it.

    I dont have enough reputation to post links though so look for SwapCity in the action category (there is no platformer category)

  • Well i understand its a pretty specific problem, I managed to post the game on newgrounds without any problem. I would like to know if there is any way to see a list of all the behaviours and/or plugins used in my game to check ?

  • If you save your game as a project in it's own folder, then use a text editor to open the .caproj file, you will see the XML details of your project.

    The part of interest looks like below:

        <used-plugins>

            <plugin author="Scirra" id="Audio" version="1">Audio</plugin>

            <plugin author="Scirra" id="Button" version="1">Button</plugin>

            <plugin author="Scirra" id="Keyboard" version="1">Keyboard</plugin>

            <plugin author="Scirra" id="Sprite" version="1">Sprite</plugin>

            <plugin author="Scirra" id="Text" version="1">Text</plugin>

            <plugin author="Scirra" id="TextBox" version="1">Text box</plugin>

            <plugin author="Scirra" id="Touch" version="1">Touch</plugin>

        </used-plugins>

        <used-behaviors />

    Your plugins and behaviors should say scirra. If there is some/any that don't, then you haven't removed them fully.

  • Well thanks a lot, it says Scirra except for that one ...

    <plugin author="Zack0Wack0/Scirra" id="WebStorage" version="1">WebStorage</plugin>

    I dont really get why Webstorage isnt accepted it is written black on white that it should be ...

  • I'm not at home to check and see if Zack0Wack0's original storage plugin is the one now included and whitelisted. But I wanted to ask if you are using the "Scirra Arcade export" when you export the game?

    I thought that might be a possibility.

  • Artsym

    Well thanks a lot, it says Scirra except for that one ...

    <plugin author="Zack0Wack0/Scirra" id="WebStorage" version="1">WebStorage</plugin>

    I dont really get why Webstorage isnt accepted it is written black on white that it should be ...

    That one should be OK as I think it was integrated by Ashley - that's why it says "Zack0Wack0/Scirra".

  • Well it was the only one that wasnt only "Scirra" so im working on another save system now.

    Paradox, ofc i wrote it right at the start "my Arcade export zip file".

    Thanks anyways i hope i can find a solution for saving the progression.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Artsym

    It might be worth just testing the Arcade export using one of the built-in examples, just get some peace of mind regarding the process.

    Just make sure you are using the very latest version - r154 - and when you select the Arcade export, click the link to automatically go to the submission page.

    Hopefully, it will all go well, and at least you'll familiarize yourself with the process (assuming you haven't done it before, obviously).

  • Looks like itwas a good idea seeing as even when i removed the whole Webstorage system the game still wont upload. Getting the same error message, i have checked, im using the latest version of Construct 2, selecting arcade export and going to the normal submission page...

    Where can i get one of the built in examples?

    thansk for all the advices btw

  • Remember - there was a new release yesterday (r155) so if you haven't already, you'll need to upgrade to it.

    Just launch C2, select 'New' and choose one of the built-in examples, or even one of the templates. Tweak if you want, then go through the export to Arcade process.

    I just recently tried it (mainly because I'd never done it) and following the instructions, it worked first time for me, so fingers crossed that you'll have the same experience.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)