0 Favourites

Strange issue with events

This forum is currently in read-only mode.
  • I am trying to make a door, it has a solid attribute, when you shoot it the solid attribute is removed and the doors opacity is lowered. When you shoot it again it is supposed to add the solid attribute and raise the opacity back to %100.

    I have to separate events which are the exact opposite of one another, I can get one at a time to work, but not both.

    here is a pic of my event sheet, what am I doing wrong?

    <img src="http://i45.tinypic.com/2r7y4w8.png" border="0" />

    PS I am still pretty new to this.

  • I think that is construct classic maybe?

    you could try separating the events.

    like this:

    • when door collides with sprite while close > set open, then destroy sprite.
    • when door collides with sprite while open > set close, then destroy sprite.
    • when door is closed > set opacity to 100 and become solid.
    • when door is open > set opacity to 20 and stop being solid.

    Sometimes the order of the instructions seems to alter the results. You could also try destroying the sprite after opening or closing the door. I know it shouldn't make a difference but it won't hurt =)

    Hope you can solve this ^^!

  • The actions of event 5 set it up so that event 6 will always run. Add a "else" condition to event 6 and that should help.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • The else command did it, thanks alot.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)