sprite on platform jiggles

This forum is currently in read-only mode.
  • hello and hi to everyone

    I wanted to participate in this forum long ago! this engine is something from other world!

    ok, let's go to the point.

    I'm trying to make a game, a platform game

    and I'm trying to make some walking, crouching, jumping, running characters...

    the thing is, the stand position and walk position, make a "jiggling" effect that makes the things wrong..

    i've followed some tutorials but still i can't figure out what i'm making wrong..

    i'm uploading the CAP file

    http://www.mediafire.com/download.php?58k1sm9z69aspwp

    i'm pretty frustated with this.. I'm trying to learn as much as I can with the tutorials, the one with the sign boards helped me with the platform behaviors. but now I'm stuck with this thing of jiggling when the camera follows..

    sorry for the grammal english. and thanks for any help

  • here you go

    fixed

    Your problem is with Hotspots for every frame in walk animation.

    Every frame of your animation have different dimensions and your hotspot was in the center of every frame. That's why walk animation looks "jiggy" (is that a word?)

    I have moved your hotspots from center-center to bottom-center - for every frame.

    (and have to resize your image due to my nvidia card).

  • whoa! that's a quick reply! and a solution with it! this is a great community! thanks a lot shinkan!

    well, i've downloaded the fixed cap and yes! seems that the damn hotspot was the problem! but...

    I've tryed to place de hotspot right in the botton too! but the sprite stand and walk "jumped" out!

    and the walk, was still making that JIGGLING with the camera (in follow mode that's why I managed to detect that flaw)

    so.. there is something in the fixed cap that still comes out. when you walk either left or right, there is a pixel height diference. almost undetectable.. but you can see that..

    why is still happening? i'm gonna check it more deeply..

    btw: you recommend that all the sprites to have the same "box" dimension?

    thanks again

  • when you walk either left or right, there is a pixel height diference. almost undetectable.. but you can see that..

    yeah I just notice that. In your Sprite (red lady) Properties set Rotation from "Normal" to "No rotation" - it coueses that strange 1 pixel jump.

    btw: you recommend that all the sprites to have the same "box" dimension?

    No, not realy - i have geforce 570 and i have to have that kind of size in construct to work properly. You can have any size you want, just to remeber to put Hotspot for every frame in specific location, but i think it's easier to have all animation ie. 128x128 with Hotspot set to bottom-center - for that kind of game.

  • about the box size of the sprites....

    i'm still getting the "jiggling" (frame jumping) even with the hotspot in the botton box..

    clearly i'm missing something

    http://www.mediafire.com/download.php?wdmdveab0vrw0dg

    can you check it? and.. the size of the character is pretty big I think, I'm pretty noob at pixe art. that's why I wanted to make them "big" somehow.. is a GUILTY GEAR X size like...

    maybe the complete pixel sprite size won't make the game "heavy" ?

    sorry for grab your arm, shinkan..

  • clearly i'm missing something

    hehe yes, you do indeed.

    Look at your frames again. This time look closely to the bottom of your sprite.

    On few frames there's a gap between sprite (red pixels) and Hotspot (or better say bottom of your frame).

    You got Platform Behavior on that sprite (to be honest I never used it) but as far as i know it detects collisions betwen "pixels of your sprite character" and "pixels of the ground sprite"

    And now you have set Hotspot to bottom for every frame - that's fine, but betwen hotspot position (very bottom) and your most bottom pixels there is small (usualy pixel or two) gap.

    And now (again) when you move, your sprite collides with the ground but it colides betwen pixels of sprite and pixels of ground, not betwen hotspot of sprite and ground.

    Look again on my cap file. I fixed that problem by moving almost every frame of your sprite down. So the bottom pixels Y position is equal to the hotspot Y position.

    or maybe you want me to make a picture with that problem area? and show you exactly whats your problem ?

  • again, awesome response, shinkan!

    I undertand the situation!

    the red line has a antialiased effect. .that's why the platform behavior make the sprite "jump" within each frame! omg. i'm so dumb! hahaha

    the problem gonna be solved when I put the PIXEL SPRITE! 'cuz they don't have that problem! and the hotspot is gonna be correct that time!

    thanks a lot shinkan! I'm gonna retake the spriting for the character! you shed light over this dumb person

  • heh no worries, glad i could help

  • well, shinkan or anyone who wants to check this and drop me another tip..

    this is the concept, now, with the pixel almost complete, just minos details in the sprites (like the hair, skirt and cape.. and face..

    but. the thing is.. THERE IS A JIGGLING IN THE WALKING!

    http://www.mediafire.com/download.php?iuxz4fxqtr8nqx2

    this time the stage is small..

    well. i'm all ears.. or eyes in this context

    thanks

  • You are doing exactly the same thing as you did first time.

    <img src="http://dl.dropbox.com/u/34375299/info.jpg" border="0" />

    Red square - Hotspot for current frame

    Blue Line - movement of that hotspot through entire animation

    Green Line - position of your ground

    Can you see what you are doing wrong? I explained everything... twice few posts above

    Edit: Next time i will send you a video ;P <img src="smileys/smiley1.gif" border="0" align="middle" />

  • yes, i've tryed that, but. i'm still having that problem.. oh god.. even with the things that shinkan told me.

    is pretty frustrating! i'm still missing something! i tryed to aling the sprites the way shinkan told me. but.. still, wont make the thing! aw man.... I'm suck so hard!!!

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I have an idea. Make your self a sprite, let say 128 pixels high. On that sprite draw a straight line across on the bottom and put Hotspot in the bottom-center.

    Like here

    <img src="http://dl.dropbox.com/u/34375299/blank1.jpg" border="0" />

    Copy that frame as many times as you need.

    Draw your characters so the feet of your character are always touching green line.

    Like here

    <img src="http://dl.dropbox.com/u/34375299/blank2.jpg" border="0" />

    Follow that rule for every frame for your animation.

  • hell yeah! thanks shinkan! that worked (I've tryied your version and changed some stuff, but in the end was your correction that made that to work!)

    here, have a check with the corrections.

    http://www.mediafire.com/download.php?txbi6tdc64gupy3

    and a friend show me some added things with the corrections

    http://www.mediafire.com/download.php?7cc0igyl2wd33ok

    this is gonna be so FUN! thanks to all . thanks a lot shinkan!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)