[SOLVED]Runtime Errors! CC wont let me run or debug my game.

This forum is currently in read-only mode.
  • Good morning everyone, just a few days ago I ran my game so I could test it and I got this message:

    [attachment=1:39edm0cv][/attachment:39edm0cv]

    So then I try to debug it like it tells me to and I get this:

    [attachment=0:39edm0cv][/attachment:39edm0cv]

    Can someone please tell me what's wrong so I can get back to working on my game? D:

  • This probably comes from your events, could you share your .cap file ?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • This probably comes from your events, could you share your .cap file ?

    I'm trying to, but it says "The extension cap is not allowed"... How else can I share it? :O

  • rghost.net / mediafire.com

  • rghost.net / mediafire.com

    Okay, I used MediaFire. Here is the link for the .cap: mediafire.com/download/vv8k13urqa16k66/DIAMONDS+THE+HORSE+LIVES+AGAIN+-+Copy.cap Thank you very much for helping me

  • I gave a look and I haven't seen anything that could cause this error :/

    I suppose that the game was working by the past, right?

    If yes, what have you done before the error appears ?

    Did you have 7 layouts by the past? (i've seen in your events "Go to layout 7") and your event sheet 3 name is Layout 7 events

  • I gave a look and I haven't seen anything that could cause this error :/

    I suppose that the game was working by the past, right?

    If yes, what have you done before the error appears ?

    Did you have 7 layouts by the past? (i've seen in your events "Go to layout 7") and your event sheet 3 name is Layout 7 events

    Yeah, this is a copy of the original. At first when I tried to put the .cap on here it was slightly too big (3.73 MB) So I made the copy and got rid of the other layouts other than the title, controls and the last layout that I was working on with the elevator. I guess now that I have the mediafire account I should post the full version. So here's that: mediafire.com/?4bgswk467df4ffi

  • Level 5 -> sprite16 -> remove the 'floors' private variable to fix it.

    Edit: You can re-add it and it should work.

    Edit2: For a technical note it would seem the variable index is 0, and it should be 1 to not crash? Craziness.

  • Level 5 -> sprite16 -> remove the 'floors' private variable to fix it.

    Edit: You can re-add it and it should work.

    Edit2: For a technical note it would seem the variable index is 0, and it should be 1 to not crash? Craziness.

    What? That's what it's been the whole time??? Holy crap! Thank you! XD And thank you too Elite. :3

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)