0 Favourites

really basic animation issue

This forum is currently in read-only mode.
  • long story "short". been doing a platformer with the bone movement behavior for my animations, but since it seems to behave rather strangely from time to time,i decided to switch to good old frame animation. i started a new cap to study and learn some basic stuff to use in my actual game,but i encountered something really strange,which prob. is really simple and obvious for someone who is a little more experienced with this.

    ive gone through platform tutorials and stuff, but i really didnt find a good,simple guide for attack/hit animations. so i fiddled around in my cap,trying to get it to work by myself, and i did. it behaves as i want it to. problem is, now my jump and fall animations arent working properly.

    when i jump or fall, it only shows one,random frame from those specific animations.

    i know its prob something really really simple and basic,but i just cant seem to find out what the problem is.

    so,i ask you,scirra community, if someone could point out my mistake in my coding,from that little .cap found below, and give me some kind of detailed explanation of what i did wrong and what is the logic behind this strange behavior.more importantly,what are some basic things to keep in mind,when working with constructs logic.

    any kind of help is much appreciated, thank you.

    CAP:

    http://dl.dropbox.com/u/11157144/platform-test.cap

    oh and nevermind about my main character, he's "special"

  • First off since collision mask are working now I'd suggest getting rid of the dummy you have the platform behavior applied to.

    You can apply the behavior to the character, and get rid of some of that 44 megs of vram.

    Tick auto rotate on the behavior, then auto flip, and auto mirror in the sprites preferences.

    Delete all the left angle animations, and be sure to update the remaining animations collision mask's.

    Now then I didn't figure out what the issue is with the random frames, but I'd venture a guess it has something to do with a negated, or inverted animation comparison.

    Inverting a condition doesn't work with everything.

  • hmm interesting.. so youre saying that i dont need that purple "carrier" anymore and i can just use my sprite? that sounds awesome,now i can spend that extro vram to something else.i knew im gonna eat up some vram doing all those animation frames,but i like my animations smooth and sort of detailed.thats good to know, thanks.

    do you have any suggestions or alternative ways on how to make the attack animation?

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • I'm having a hard time with collision masks. I can't tell why, but when editing the mask I often end up with having no mask at all, if I try to copy one to all frames. I needed to edit the collision mask, because there are areas that shouldn't collide (e.g. long hair). I finally went back to the old method^^

  • I'm having a hard time with collision masks. I can't tell why, but when editing the mask I often end up with having no mask at all, if I try to copy one to all frames. I needed to edit the collision mask, because there are areas that shouldn't collide (e.g. long hair). I finally went back to the old method^^

    I had the same problem. The other issue I was having if I had frames with different sizes and shapes, the size of that collision mask had to be the same and I'd have to set it for each frame, and I'm not going to do that for 1200 frames across several objects. If anything, the collision mask should be treated as a separate animation, and if the collision mask changes (which shouldn't happen often or ever) you could simply tell those different frames or animations to reference a different collision mask. Don't get me wrong it is an excellent idea, it just needs some work.

  • so i finally got it to work like i wanted, after fighting with it for quite some time. went through a lot of different possibilities, and frankly im still not sure about the logic behind this odd behavior.it left me wondering if my code is at all suitable for any possible future animations.

    but anyway,here's the fixed .cap if anyones interested in analyzing the difference and maybe shed some light on what i did wrong in my previous .cap:

    http://dl.dropbox.com/u/11157144/platform-test2.cap

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)
Similar Topics Posts Views Last Post
Unread hot topic
1,941 263,227
FlyingRam's avatar
FlyingRam
Unread hot topic
300 118,422
blackhornet's avatar
blackhornet
Unread hot topic
0 Favourites
Spam issue
201 16,833
Tom's avatar
Tom Construct Team Founder