0 Favourites

layout object... throws objects in layout all over

This forum is currently in read-only mode.
  • <img src="http://upload.dfyb.net/uploaded/position_error.png">

    top half shows in-construct view, bottom half shows runtime

    so i'm building an options screen using the layout object. the text object seems to place itself fine, but as you can see, the buttons and drop down box have a disagreement. i haven't confirmed it, but they seem to be placed where they would be if the modal layout was up and to the left at 0,0 instead of where it is actually placed, near the middle of the screen. the inlayed layout is fewer pixels w/h than the layout it loads into, so i figure this skipped passed testing when they put in this feature.

    preparing to write a bug report -- just wanted to post a thread to make sure i wasn't doing anything wrong.

    edit: a secondary problem... for some reason the first button press of "o" doesn't open the options... but after that it'll open/close it every time

  • Seems controls create at their position relative to the application window; they'll need to be modified to show relative to their layout. Good find.

  • Seems controls create at their position relative to the application window; they'll need to be modified to show relative to their layout. Good find.

    i also noticed that if, for example, i placed a sprite -- it would correctly APPEAR to be located where i placed it. but when i want to click on the object, i would need to click over to the left in the incorrect position.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • That's quite possibly this bug.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)