0 Favourites

Everything went fine, then things started to crash

This forum is currently in read-only mode.
  • Hi!

    Got a bit of a problem.

    Working on a small top down RPG-like game, and suddenly it just crashes when I run the game.

    Nothing happens, I just get a "This application have made an error ... blah blah ... notify Microsoft" message. :/

    Here is the .cap file that I'm working on: http://www.mediafire.com/?2hibs15jtda

    Do I need to upload the images used in it as well, or are they inside the .cap file?

    Controls if you get it to run: CTRL to pick up stuff (A sword at the moment), SHIFT to use what you are currently carrying. Yellow rotating things is just placeholders for money and cannot be used (Automatically picked up if walked over)

    Thankful for any help.

    Edit: Might add that I'm using the 0.86.2 version.

  • Haha awesome game, reminds me of Thor or Golden Axe Warrior!

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • So it works for you? Strange. That version is unplayable on my computer. But congrats on getting it to run and thanks for enjoying it. <img src="{SMILIES_PATH}/icon_smile.gif" alt=":)" title="Smile" />

    I added some new graphics to the maps and suddenly it works for me again. This leads me to believe that there is some nasty bugs in the sprite lists or whatever they do behind the scenes. <img src="{SMILIES_PATH}/icon_smile.gif" alt=":)" title="Smile" />

  • that's was pretty fun to try out!

  • It works for me too. And yeah, it is pretty fun. That's one big-ass sword.

  • Thanks for trying it out and that you liked it. <img src="{SMILIES_PATH}/icon_smile.gif" alt=":)" title="Smile" />

    I wonder what caused the crashed I had with that version.

    Oh well.

    More to come. This is an entry I'm working on for the Retroremakes competition. I will post more versions when I have something new to show. <img src="{SMILIES_PATH}/icon_smile.gif" alt=":)" title="Smile" />

  • Combined long eventless nightshift hours at work with some Construct usage.

    Seems that the bug with the exploding EXE shows up at random intervalls. And it looks like I can get it to go away by closing down Construct and reopen it again.

    So it looks like it have something to do with the EXE producing code. Buffer overflow?

  • I've heard someone else saying the preview sometimes crashes. Probably something dodgy going on with memory during preview. I'll review the code.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)