0 Favourites

Crash when restart layout.

This forum is currently in read-only mode.
  • Hi guys...

    I come here desperate...

    I did one layout for the first level of my game and one layout with "Continue" or "Game Over". So, when I try to Continue and come back to first level construct crash and that msgs appear:

    An unexpected error occurred and the apllication was terminated.

    You may be able to find out more information about the crash by Debugging, and attempting to reproduce the bug.

    Temp.exe - Application Error

    The instruction at "0x00427213" referenced memory at "0x018bf158". The memory could not be "read".

    Click on OK to terminate the program

    Temp.exe - Application Error

    The Instruction at "0x7c910a1b" referenced memmory at "0x00000003". The memory could not be "read".

    Click on OK to terminate the program

    I saw somethings in other threads about restarting a layout. I did not understand very well and seemed very laborious because is not like TGF. When i opened again the same layout it's restart automatic (not global value i guess). So, I don't know what i need for fix this.

    Sorry sux English and thanks guys.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Is this the same when you export the game? or just preview it from the editor?

  • I never exported the game. Just in preview.

  • Try exporting the game and see if that fixes your issue. Sometimes preview can be strange, especially on Windows Vista/certain computers.

  • Nothing. I exported but still with the same error.

    I use windows xp. I don't know if i need to do something in event when restart. Maybe is error because my character is dead ? '-'

  • This can happen for a whole bunch of reasons that I can't even remember, but try deleting the xaudio object if you're using. If that's the problem, switch to audiere.

    Generally the process you should use is to eliminate objects until it doesn't crash. When I'm trying to figure out something like this I make a new save and just shred the game until the problem stops. Then I can figure out the source and fix it.

  • Thank you guys for help. Not found the problem and now I'm convinced to give up the project. Sad because I had already done a lot things. If after I have courage to start a new project I'll do it in tgf. Thanks again.

  • Niiccs

    My bet is the crash is caused by the "OR" condition. It often works fine until a layout restarts. The solution is to not use it at all in Construct Classic. Other than that I can't think of any other cause. If that doesn't fix it pm me the cap and I'd be happy to take a look.

  • AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA !!!

    I LOVE YOU R0J0hound !

    I don't know very well use the Construc so I lost fast my hopes to fix the bug. But you come and save my game ! (Noob game but for me is to much ! xD)

    Really thanks and thanks again to Jayjay and Kayin to help too !!!

    Obs: I can't send to you my cap because i don't have REP. But I'll send when i finish the game for you see my noob game and to laugh at my sux programming. xD

    Obs2: Sorry sux english.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)
Similar Topics Posts Views Last Post
Unread hot topic
132 29,603
chadorireborn's avatar
chadorireborn
Unread hot topic
72 6,907
Josek5494's avatar
Josek5494
Unread hot topic
52 8,563
BluePhaze's avatar
BluePhaze