Why does text not appear properly and how do I fix it?

  • I've been working around this recently, but I really want to know what I've done wrong (or if this is a bug - it probably isn't).

    Note: Just to clarify, there is no event sheet attached to this layout.

    So in the layout editor, this is what the layout looks like:

    But when I run the layout, this is what the layout looks like.

    It only happens with text, and it's very annoying - I've had to do this:

    To get this:

    Thanks in advance!

    Eliclax

  • Did you check Configuration Settings in your project properties? What's probably suspect in full screen scaling settings (try turnin fullscreen off completely, though), high-dps display, and sampling, besides maybe downscaling. As well as possibly Pixel rounding.

  • Did you check Configuration Settings in your project properties? What's probably suspect in full screen scaling settings (try turnin fullscreen off completely, though), high-dps display, and sampling, besides maybe downscaling. As well as possibly Pixel rounding.

    I just tried changing all of those, one at a time, but unfortunately, nothing seemed to work.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Welcome to text rendering where the font used and the results obtained vary from a browser to another.

    Though in your example what is not really obvious is if the character "<" and the word "Settings" are in the same text object ?

    My guess is they are not, and you are even possibly using a TextBox object in the mix which makes alignment even more difficult.

    Apart from correcting in the layout for each platform you are aiming to release on there is no solution I know of for such issues. Apart maybe using SpriteFont, but SpriteFont then bring their own set of difficulties and issues.

  • Welcome to text rendering where the font used and the results obtained vary from a browser to another.

    Though in your example what is not really obvious is if the character "<" and the word "Settings" are in the same text object ?

    My guess is they are not, and you are even possibly using a TextBox object in the mix which makes alignment even more difficult.

    Apart from correcting in the layout for each platform you are aiming to release on there is no solution I know of for such issues. Apart maybe using SpriteFont, but SpriteFont then bring their own set of difficulties and issues.

    Great......

    And btw, The "<" isn't a character, it's actually a sprite. Which probably explains why it stays in the same place.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)