0 Favourites

Pixel alignment issue in editor

  • Hey all!

    Here's my issue: I'm trying to align aliased tiles with each other, which works fine in Photoshop; however, in Construct 2, some tiles will have this issue:

    http://i.imgur.com/pVKwu.png

    The whole thing will be exactly one pixel out of alignment, and using the left / right arrow keys overshoot that pixel by one and leave it too far on the other side. Both tiles have the same width both in actual pixels and in the editor.

    Is this a resolution issue? Also, when creating small-scale assets (think 10x10 pixels), is it better to upscale the tiles previous to importing, or would it be just as effective to have Construct do the scaling for me?

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • It's the way things are rendered in browser - I've been doing pixelated stuff by blowing up, in order to save memory and disk space, and occasionally things won't reach.

    I'm assuming you're using a grid to line everything up?

    Are the tiles on-grid, and integers? IE, if tiles are 10, grid points are multiples of ten, and x,y co-ods aren't something like 10.1256 , which can happen when nudging by cursor keys.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)
Similar Topics Posts Views Last Post
Unread hot topic
300 118,427
blackhornet's avatar
blackhornet
Unread hot topic
0 Favourites
Spam issue
201 16,837
Tom's avatar
Tom Construct Team Founder
Unread hot topic
157 12,693
megatronx's avatar
megatronx