0 Favourites

MIME settings : mp4 added but still no sound in IE

  • Hello,

    I've added the recommended MIME settings in order to get sound and web storage, application/manifest+json etc. going but my apps still don't produce sound when played online.

    The images bellow shows that the entry is there.

    My host isn't particularly helpful and more or less insists that the problem has to be solved within my app code.

    When tested locally, my apps do function as expected when opened / previewed with IE.

    If anyone has some additional info besides what is in the manual, I'd be most grateful to finally fix this last annoyance.

    For what it's worth, I'd be willing to move to a new host if I have to (so if your sound works in IE, please tell me who you are hosting with?).

    Thanks,

    vancouver

  • blackhornet

    been there, done that!

    (Just to be on the safe side, I double checked ALL required mime types as specified in the manual and they are all there).

    I don't know what else I can do?

  • audio/mp4 is exactly: .m4a

    Nothing else, don't skip the dot!

  • Just for the fun of it, I've added "audio/mp4" with the extension ".m4a"

    Now I guess that the server will take some time to update so, I'll test again in a few hours.

    It would be amazing if I could get sound in IE!

  • Alright, it's time to consider plan B!

    Thos of you who have sound working in IE, PLEASE post with whom you are hosting.

    I am willing to change webhost if I have to.

    So??? Is bluehost capable of doing this?

  • I was just told by tech support that IE does not support mp4 sound.

    So HOW do I fix this?

  • They are wrong. You can point them at Microsofts IE site that clearly states M4A is the audio format supported.

    http://msdn.microsoft.com/en-us/library ... 85%29.aspx

    (Maybe try again without the dot - it may depend on the underlying system if the dot is needed or not.)

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • thanks black hornet. I will add one more entry ... but to be honest, I am ready to move on.

    With all the apps begin released over the next weeks and months, I should pick up some considerable traffic for http://littlecomposers.com and maybe it's best to upgrade my hosting and find a host which can do what i need.

    I really appreciate your advice! <img src="{SMILIES_PATH}/icon_e_smile.gif" alt=":)" title="Smile">

  • Did you also read the section about offline caching in https://www.scirra.com/manual/168/mime-types?

  • Ashley

    Thank you for posting that link!

    I have become VERY familiar with it because somewhere in there lingers that one little word which just might fix my problem.

    To have others look at what might be the issue, I am posting the "relevant" lines here BUT I am checking each line which you have written in the Manual (MIME types for HTML5 games)

    System MIME Types

    01 text/html : .shtml .shtml .shtml .shtml html htm shtml

    02 application/javascript : js

    03 audio/ogg : oga ogg spx

    04 video/webm : webm ?? > C2 manual states ".webm"

    05 video/mp4 : mp4 mp4v mpg4 (no dot!)

    06 text/csv : csv (no dot)

    07 application/json : json (no dot)

    08 image/svg+xml : svg svgz

    09 application/pdf : pds (no dot)

    10 application/octet-stream : bin dms lha lrf lzh so iso dmg dist distz pkg bpk dump elc deploy

    User Defined MIME Types

    21 audio/mp4 : .m4a m4a (with and without dot)

    22 text/cache-manifest : .appcache

    23 application/font-woff : .woffe

    24 application/x-web-app-manifest+json : .webapp

    25 application/manifest+json : .manifest

    26 text/xml : .xml

    NOT added:

    video/ogv

    Upon closer examination, I see the some extensions have missing dots.

    What I will do now:

    Change the URL for a game (make a new dir/subdir and see if it works????)

    It would be awesome to get sound working in IE but if the new directory/upload doesn't fix it I will talk to a new host, and ask if they can give me a 24 hr test account.

    Sound in IE is the last hurdle to be fixed before school starts again.

    Thank you,

    V

  • Today, July 6, 2014, at the 10th minute, of the 10th hour, Little Composers, for the first time in history, functioned as expected, for those earthlings who, for what ever reason, use Internet Explorer! CNN, Global TV and SHAW Cable will broadcast the event on the evening news tonight. But remember. You read it here first! Life is good!

  • Now that the medication has kicked in and the dancing stars have faded,

    here is an image of which "Custom MIME Types" I have added to make it work in IE.

    Hopefully, this saves someone else the headaches I had with this.

    Thanks to everyone who pointed out the obvious!

    REMEMBER! If you add the custom MIME types, you still need/should re-create the apps in new directories because of server caching issues. Creating a new dir for your games (and updating the links to it) will bypass the expiry/waiting time and you will have sound right away.

  • My apps function now on all major browsers ....

    Today, I needed to tweak something on the server and when I opened the .htaccess file, I noticed that the following lines have been added:

    AddType application/manifest+json .manifest

    AddType application/font-woff .woff

    AddType application/x-web-app-manifest+json .webapp

    AddType audio/mp4 .m4a

    AddType audio/mp4 m4a

    AddType text/cache-manifest .appcache

    AddType text/xml .xml

    Maybe this helps someone (it was a mess to get this going).

    Cheers,

    V

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)