keyboard doesn't work on mac. after exporting..

  • i just exported my game . and when i played on pc . it worked good. but when i tryied to play on mac the keyboard didnt work.

    whenever i press any key it just give buz sound like it does.. if you use mac you would know., does any have or had similar prob in the past. need help...

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Bump because I'm having this issue too.

    Plugged in my gamepad and it worked fine but just the error tone for anything on keyboard.

  • I should also mention that I copied my exported nw.js file to a flash drive and then from there to my mac. Potential permission errors?

    I also did a super basic .capx and that worked fine after I clicked on the window. However my game requests fullscreen and jumps in to it and I think that is where the issue is. Looking in to it now.

  • Okay so it's definitely related to going full-screen on mac in nw.js with my build. Game works fine and great windowed but the moment I full-screen it, it completely ignores all keyboard input. I feel like it thinks the window isn't in the forground?

    I have a fullscreen request at the beginning of my game. It can also be toggled via esc. Even with the request disabled at the beginning and full-screen being toggled later, it still ignores the keypad.

    Again - game works fine windowed and full-screen with gamepad.

  • Thanks Mann , i will definitely try this.. thanks

  • CodeArtOnline Hey I was browsing through the manual and saw that the nw.js object has a "set always on top" action. So I *think* if you set this action to trigger/true only while in full-screen, it may work. This is assuming that nw.js doesn't think that the fullscreen is in focus/on top. I'm at work right now or I'd try it out

    I can definitely try it out tonight and get back to you.

  • @CodeArtOnline This worked for me!

    -Add the nw.js object to your layout

    -Request "always on top" while in fullscreen.

    What I have pictured is my fullscreen toggle (pressing ESC). I also have a fullscreen request during "on start of layout" on my very first layout. If you do the same, add the "always on top" request there as well.

    Note: I had to click inside the window for it to recognize the keyboard. After that, worked great!

  • Man ur a wizard thankssss i will try it out.. but it will work i can sense it .. Thankssssss a tonn

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)